Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1 (Edited)
1995 DeVille 4.9L

CEL came on about a week ago, throwing code P048, for EGR system trouble. Found a website about common EGR problems, for I figure it's worth a shot.

This morning I try to remove the EGR, but I can't get to the bolts so I decide to remove the throttle body. I got everything disconnected except for a couple tubes, and decide it's out of my ability. So I put everything back together, but the rubber hose slip-connector thing for the small metal tube from the transmission to the throttle body broke in two. One half was large enough that it could fit over both ends, though.

I make sure everything is connected and start her up just to make sure. The idle was kinda rough, and it didn't feel like it had all its power. The most noticeable difference is throttle response...from a stop when I push on the gas, it hesitates for a split second and sounds like the engine stops completely during that time. If you push on the gas very slowly from a stop, it'll die.

So, what did I F up this time?

Thanks......
 

·
Registered
Joined
·
14,607 Posts
probably a vaccum leak , it might just be from that partily broken line.... or it needed the intake manifold to throttle body gasket replaced after removing the throttle body (tore up gasket) i have the torque specs for the TB but i cant find them at the moment , might just be the bolts were never tightend down , it isnt much to get it tight tho only like 30 ft lbs or something ill go check
 

·
Registered
Joined
·
14,607 Posts
yah thats pretty much what katshot posted in that thread link i posted :

The only specs I could find were for the throttle body and the intake manifold.
TB - 14 lb/ft.
Intake -
Step 1 - 8 lb/ft.
Step 2 - 12 lb/ft.
Step 3 - Repeat step 2
The sequence is from the center out alternating from side to side.
I doubt there's a spec for the EGR valve. Just use your best guess. Snug but not torqued like with a 1/2" breaker bar

__________________
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
Thanks guys....I was on the brink of selling it when the stupid CEL came on...then this happened! Piss me off.......

Come to think of it I think a chunk of the TB/manifold gasket came off. And that stupid rubber connector biatch thing.
 
1 - 6 of 6 Posts
About this Discussion
5 Replies
3 Participants
Spreng
Top