Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
2006 dts
Joined
·
6 Posts
Discussion Starter #1
I have a 2006 dts and have for the second time had a problem with getting it started. The first time it happened I turned the ignition to crank it and all my dashboard warning lights came on and stayed on (traction control, check engine, abs) and car would not attempt to crank. I also noticed gear indication light was not on and I couldnt move the gear shift at all. I also notice fuel gage wasn't working either. I knew it wasn't the battery cause everything was working as far as power. I troubleshot for 3 days by disconnecting battery for 30min ,checking fuse and relays etc. I thought water may have gotten somewhere or something . Well I got it towed after 4 days of trying to get it to crank. I tried cranking it before we put it on the wrecker , nothing happened. They got it to the a little shop around the corner and tried cranking it and cranked right up on the first try and every try after that. The mechanic said he couldn't fix what wasn't broke. I left it there an extra day to see if it would crank and it did. They ran a diagnostic on it and there were no current codes but a previous history of no communications ECM and I think TCM. I drove it for 2months no problem but now yesterday it doing the same thing.



CAN SOMEONE PLEASE POINT ME IN THE RIGHT DIRECTION!
 

·
Registered
'06 DTS performance; CowboyCadillac='12 SVT Raptor; 2014 XTS-Vsport
Joined
·
634 Posts
Check all ..... ALL , your ground connections. Remove, clean, reinstall.
 

·
Registered
2007 DTS
Joined
·
225 Posts
I have a 2006 dts and have for the second time had a problem with getting it started. The first time it happened I turned the ignition to crank it and all my dashboard warning lights came on and stayed on (traction control, check engine, abs) and car would not attempt to crank. I also noticed gear indication light was not on and I couldnt move the gear shift at all. I also notice fuel gage wasn't working either. I knew it wasn't the battery cause everything was working as far as power. I troubleshot for 3 days by disconnecting battery for 30min ,checking fuse and relays etc. I thought water may have gotten somewhere or something . Well I got it towed after 4 days of trying to get it to crank. I tried cranking it before we put it on the wrecker , nothing happened. They got it to the a little shop around the corner and tried cranking it and cranked right up on the first try and every try after that. The mechanic said he couldn't fix what wasn't broke. I left it there an extra day to see if it would crank and it did. They ran a diagnostic on it and there were no current codes but a previous history of no communications ECM and I think TCM. I drove it for 2months no problem but now yesterday it doing the same thing.
CAN SOMEONE PLEASE POINT ME IN THE RIGHT DIRECTION!
Check battery for dead cell. My battery went out last year. It would go from a full charge to dead in a 5 minute drive to the store. (This actually happened, battery just came off the charger, was "full" then drove a few miles and went to the store, minutes later completely dead!) Changed battery, problem went away.
 

·
Registered
2005 CTS/ 2008 DTS/ 2008 STS V8 N*/ 2011 CTS4 ALL W/D Pearl
Joined
·
688 Posts
billdaman is probably right. The battery you bought should still be under warranty, demand a new one and let's hope that is the problem.:thumbsup:
 

·
Registered
'06 DTS performance; CowboyCadillac='12 SVT Raptor; 2014 XTS-Vsport
Joined
·
634 Posts
Yup, do a battery Load Test.
What Bill said is correct.
Voltage is not always a good indicator of battery condition.

Also, even if the battery was good, the connections to the Body and/or Engine may be compromised.
 

·
Registered
2011 DTS Platinum
Joined
·
4,633 Posts
One ground to be sure to check is where the battery cable connects to the floor of the car.
Take that one loose from the floor.. use sandpaper to remove a little bit of the paint on the floor of the car, so that it will have a good connection.
 

·
Registered
2006 dts
Joined
·
6 Posts
Discussion Starter #7
Im still having the same problem with my dts . While driving the gear indication light flickers on and off while in drive causing the abs, traction control & service stabilty lights to come on and all guages (speedometer, fuel guage, & rpm) stop working . Also the door locks unlock and lock when the gear indication light flickers too. Ive checked my ground to the battery and even replaced the still the same problem and it happening more frequently now. Can someone please point me in the right direction.
 

·
Registered
2006 dts
Joined
·
6 Posts
Discussion Starter #8
I think I figured put the problem with my dts having all the lights come on over the dash along with the gear indication light blinking and locks cycling up and down! I just had a tcm I bought of installed at the dealer for $221.00 part online was I$ 50 . So far no problem . Usually dash would go crazy by now .
 
1 - 8 of 8 Posts
Top