Cadillac Owners Forum banner
1 - 10 of 10 Posts

·
Registered
2004 Deville
Joined
·
194 Posts
Discussion Starter · #1 ·
2003 Deville , rebuilt EBCM , installed and ABS,BRAKE,TRACTION lights are still on . Getting the following codes

IPC U1000
MSM B2365
PCM P 1571
PCM P1644
PCM U 1040
SDM U 1000

What else could it be
 

·
Registered
98 DeVille, 97 DeVille d'Elegance
Joined
·
7,341 Posts
Come on Bob... You been here long enough to know to post definitions... Don't forget History or Current. P codes set Ses light.
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
21,524 Posts
Come on Bob... You been here long enough to know to post definitions... Don't forget History or Current. P codes set Ses light.
==========================:yeah:==:dammit: ===:rolleyes:
 

·
Super Moderator
2010 DTS
Joined
·
88,785 Posts
Those don't look related. Brake & T/C lights should be accompanied by C (chassis) codes.
 

·
Registered
2004 Deville
Joined
·
194 Posts
Discussion Starter · #5 ·
IPC U1000 , class 2 communication malfunction
PCM P1571 , traction control torque request circuit
PCM P1644 , traction control delivered torque output circuit
PCM U1040 , loss of class 2 communications with ABS
SDM U1000 , invalid or missing data for primary ID
 

·
Registered
98 DeVille, 97 DeVille d'Elegance
Joined
·
7,341 Posts
Are those current? Were those codes same before new unit and have you cleared the codes and see wht comes back?
 

·
Registered
2004 Deville
Joined
·
194 Posts
Discussion Starter · #8 ·
2003 deville with 160,000

Couldn't get the other thread back up

ABS BRAKE TRACTION all on. Sent EBCM out for rebuild. They said it seemed OK . Reinstalled and now the WBCM won't read . Following codes before and after reinstalling the ENCM .

IPC U1000 , class 2 communication malfunction
PCM P1571 , traction control torque request circuit
PCM P1644 , traction control delivered torque output circuit
PCM U1040 , loss of class 2 communications with ABS
SDM U1000 , invalid or missing data for primary ID
 

·
Registered
2011 DTS Premium w/1SD | 1999 Deville Base (RIP @179K Miles)
Joined
·
562 Posts
Check if the connectors are clean, if they are, find a factory service manual and search for the wiring diagram for the EBTCM. Then test for continuity for each wire.
 
1 - 10 of 10 Posts
Top