Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter #1
The DVD eject was stuck in a continuos loop for quite a while. It fixed itself a mile away from the dealer.


I took the car our today. It's new and this morning had 130 miles on it.

Anyway, I forgot to turn on the stereo/gps via the knob and got concerned. Anyway, it was at this point I tried ejecting the DVD. That's when the problem started.

There was a mechanical whine like it was trying to eject the disc, but no luck. This continued for a little bit (like every 30 seconds it would "try" again for a few seconds, then fall silent for another 30 seconds). I turned on the stereo/gps and it said no DVD was in the drive. Still the sound cycle would continued. I tried clicking the eject button again, holding the button down, double-clicking... no dice.

I turned off the car for a few minutes, got out, waited a minute, got in again, and then started the car again. The whine cycle continued.

I got annoyed at this point. It was my 4th day with the car. So I decided to drive to the dealer. For the entire trip the whine cycle continued until about a mile away from the dealer. I clicked the button again and the disc came out. I decided to skip the dealer for now as I had to meet some people for the evening.

Anyone notice this problem before?

I could only think of 2 things:
  1. Something is seriously broken with the eject.
  2. Something was frozen (temperature wise) in the dash.
This was in NJ about 4:00PM. It was about 42 degrees outside. So while it may have reached freezing temps the night before it shouldn't have been frozen and that point.

I'll probably take it to the dealer tomorrow, but I was wondering if anyone else had ever seen something like this.
 

·
Registered
1970 Eldorado.
Joined
·
4,023 Posts
If it's still under warranty just take it in for service. They replaced my whole Nav/audio unit when my tv function did not work anymore. Solves the chipping buttons problem too ;)
 
1 - 2 of 2 Posts
Top