Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Cadillac Technician
none
Joined
·
11,051 Posts
It seems as though I recall it being in a grommet in the end of one of the valve covers.
Maybe towards the top of the valve cover.

Maybe I remember it being in the middle of the hose between the intake and the valve cover?

It is hard to say and we don't see many of them anymore.
 

·
Registered
93 Sedan Deville 4.9L
Joined
·
1,005 Posts
Its covered in gunk lol. Pop the hood and go to the drivers side, at the very front of the car you will see a silver pipe running horizontally, it is at the end of that, right at the bend. One end fits in the silver pipe and the other end is into the engine..

I replaced mine and was hard to find without knowing before hand since it had oily residue
 

·
Registered
76 Eldo (54k), 76 Eldo (52k), 78 Eldo (9k), 85 Deville (43k)
Joined
·
668 Posts
Yup, it's in the front valve cover facing the radiator (NOT the firewall). Remove the plastic beauty cover that's held on by a single screw and it's under there.
 

·
Registered
Cadillac
Joined
·
18 Posts
Discussion Starter #7
thanks for the help, as i guessed 14 yrs and 43k miles and it was never changed...i pulled out a nice dirty ROCHESTER PCV valve. i wouldve never of thought of pulling that cover off on top of the valve cover. Thanks again!
 

·
Registered
1993 Eldorado, 4.9L, 200k miles
Joined
·
273 Posts
Oops...my bad to send you to the wrong valve cover. Glad you found it and thanks to the others folks for correcting my error.
 

·
Registered
93 Sedan Deville 4.9L
Joined
·
1,005 Posts
thanks for the help, as i guessed 14 yrs and 43k miles and it was never changed...i pulled out a nice dirty ROCHESTER PCV valve. i wouldve never of thought of pulling that cover off on top of the valve cover. Thanks again!

hehe, I forgot you have to pull that cover off, My cover broke off years ago :bigroll:

Glad you found it
 
1 - 9 of 9 Posts
Top