Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
160 Posts
Discussion Starter #1
99 Deville Concours. Taking a nice city stroll today and decided to park and all of a sudden I went to pull in the parking spot and: SERV STABIILITY SYS pops up. I clear the code and instantly it pops back up. So I clear the code agian and it stays off for a while but eventually it will come back. My main question is how involved is this to fix, and where is it? Thanks in advance!!
 

·
Registered
Joined
·
54 Posts
fristim said:
My main question is how involved is this to fix, and where is it? Thanks in advance!!
Base of steering column, on the interior side of the firewall.

The entire column needs to be removed from the car and placed on a workbench. The new sensor will come already centered, but needs to be installed properly.

My question to you is... just what makes you so sure that it's the sensor that's bad? What about the harness connection? What about one of the wires between the sensor and module? What about the module itself? Is there a software update that fixes this fault code, negating the need for a part replacement?

Not having a proper diagnosis by a qualified technician is quite a risky venture.

:lildevil:

--
Ellisss
 

·
Registered
Joined
·
160 Posts
Discussion Starter #3
ellisss said:
Base of steering column, on the interior side of the firewall.

The entire column needs to be removed from the car and placed on a workbench. The new sensor will come already centered, but needs to be installed properly.

My question to you is... just what makes you so sure that it's the sensor that's bad? What about the harness connection? What about one of the wires between the sensor and module? What about the module itself? Is there a software update that fixes this fault code, negating the need for a part replacement?

Not having a proper diagnosis by a qualified technician is quite a risky venture.

:lildevil:

--
Ellisss
Haven't had it looked at yet just got the code last night I was just wondering what the worst case senerio would be, so then I would take it that changing out this sensor is not a DIY'er type of deal?
 

·
Registered
Joined
·
54 Posts
fristim said:
...so then I would take it that changing out this sensor is not a DIY'er type of deal?
Short answer: No, it isn't for the do-it-yourselfer.

Long answer: It depends. Can you answer yes to all of the following questions?

1. Can you (or do you feel comfortable) removing the entire steering column from the vehicle?

2. Do you know how to safely and properly disable the SIR system, in order to prevent unwanted and highly dangerous deployment of the airbags?

3. Are you in possession of a decent OBD2 scan tool so that you can properly diagnose the system and prevent the changing of a part that is actually not at fault? (no, the on-board diagnostic interface through the car's climate control system won't do.)

4. Do you have access to GM TSB's and diagnostic/repair procedures? The new sensor, (if that is indeed the problem), will need to be checked after install for proper calibration.

5. If the ABS module (the controller for the system that uses the steering wheel position sensor) or the PCM need to be reprogrammed, do you have access to both the new software and a tool that will do the reprogramming?

A 'no' answer to any of the above questions means you shouldn't do it yourself.

Please remember, fristim, that you don't even know if the problem is actually the sensor itself. It could be any number of other possibilities... such as a falsely set code, a module needing updated software, a poor harness connection, a single wire being chaffed or pinched, etc.

I'm just trying to help you, and prevent you from buying a somewhat expensive sensor without first knowing for sure if the sensor is at fault.

:rolleyes:

--
Ellisss.
 

·
Registered
Joined
·
7 Posts
I have the exact same problem with my 89 Sedan DeVille. I keep clearing the codes and hours, or even a week, will go by and then the "Serv Stability Sys" light will ping back on. Usually it is just the "C1287H Steering Sensor Rate Malfunction" code, but twice it has also shown "C1286H Steering Sensor Bias Malfunction".

NOTHING feels wrong with the car. How bad is it to keep putting off taking it in to a dealer? I want to wait until my husband gets back from overseas. Is it unsafe to keep driving it with this problem?

I would appreciate ANY feedback....
vlb90


ellisss said:
Short answer: No, it isn't for the do-it-yourselfer.

Long answer: It depends. Can you answer yes to all of the following questions?

1. Can you (or do you feel comfortable) removing the entire steering column from the vehicle?

2. Do you know how to safely and properly disable the SIR system, in order to prevent unwanted and highly dangerous deployment of the airbags?

3. Are you in possession of a decent OBD2 scan tool so that you can properly diagnose the system and prevent the changing of a part that is actually not at fault? (no, the on-board diagnostic interface through the car's climate control system won't do.)

4. Do you have access to GM TSB's and diagnostic/repair procedures? The new sensor, (if that is indeed the problem), will need to be checked after install for proper calibration.

5. If the ABS module (the controller for the system that uses the steering wheel position sensor) or the PCM need to be reprogrammed, do you have access to both the new software and a tool that will do the reprogramming?

A 'no' answer to any of the above questions means you shouldn't do it yourself.

Please remember, fristim, that you don't even know if the problem is actually the sensor itself. It could be any number of other possibilities... such as a falsely set code, a module needing updated software, a poor harness connection, a single wire being chaffed or pinched, etc.

I'm just trying to help you, and prevent you from buying a somewhat expensive sensor without first knowing for sure if the sensor is at fault.

:rolleyes:

--
Ellisss.
 

·
Registered
Joined
·
7 Posts
fristim said:
99 Deville Concours. Taking a nice city stroll today and decided to park and all of a sudden I went to pull in the parking spot and: SERV STABIILITY SYS pops up. I clear the code and instantly it pops back up. So I clear the code agian and it stays off for a while but eventually it will come back. My main question is how involved is this to fix, and where is it? Thanks in advance!!
fristim, I've read this whole thread... what happened in this case with your steering sensor? Was it a major job at a dealer? Lots of $$$?
I've noticed my "Serv Stability Sys" light comes on after slow driving like cruising a parking lot or going through a drive through. I'm wondering if something is getting too hot.
Thanks for any help,
vlb90
 

·
Registered
Joined
·
36 Posts
Recently had that same code on my 98 sts. Checked all the wiring and decided to replace it(steering wheel position sensor)..... 5 minute job for me. Only one bolt under dash at steering knuckle. According to my service manual it positions itself once properly installed, but thats a seville...
 
1 - 7 of 7 Posts
About this Discussion
6 Replies
4 Participants
CadCrazy
Top