Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2007 Escalade
Joined
·
47 Posts
Discussion Starter #1
So my drivers side heated seat doesn’t work. I hear it click on then within 5 seconds shuts off. Passenger side fine. I have already replaced the burnt connector under the passenger seat. Any ideas? Should I just bypass the connector?
 

·
Registered
2007 Cadillac Escalade ESV
Joined
·
29 Posts
My 2004 Suburban it does the same thing. The bottom seat heater grid I am 99% positive has a short in it because it sees the most use. If the circuit seems to much resistance then it shuts off to keep from catching on fire.
 

·
Registered
2013 Cadillac Escalade Platinum ESV
Joined
·
18 Posts
My heated seats work but I hate that you CANT LEAVE THEM on so when you remote start and its 5 degrees out they are on! Miss my Subaru lol
 

·
Registered
2005 STS V-8 1SF Magneride HUD/ACC, 2008 Escalade ESV 1SZ Y91 Luxury Edition
Joined
·
1,319 Posts
My heated seats work but I hate that you CANT LEAVE THEM on so when you remote start and its 5 degrees out they are on! Miss my Subaru lol
You sure about that? I can on my STS. It's in the personalization menu what you want to come on with remote start.

Edit: Seems like it's automatic on your 13. From the manual: "During a remote start, the climate control system will default to a heating or cooling mode depending on the outside temperatures. During a remote start, if the vehicle has an automatic climate control system and heated seats, the heated seats will turn on during colder outside temperatures and will shut off when the key is turned to ON/RUN. If the vehicle does not have an automatic climate control system, during remote start, you will need to manually turn the heated seats on and off."
 
1 - 5 of 5 Posts
Top