Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
209 Posts
Discussion Starter #1
My V always had driveline clunking and the dealer diagnosed it as "normal". It seems to be getting worse and harder to drive without clunking. Its getting annoying. Does this mean anything? Rear? Broken mount somewhere? Thanks.
 

·
Registered
'04V, '05V, '06SRT8, '10V, '13ZL1, '12 V, '16 Z06 SC757
Joined
·
6,440 Posts
Most likely a bushing. I've had two replaced and it's night and day.
 

·
Registered
Joined
·
321 Posts
I'm waiting for my service manager to call me back with a scheduled time to change the bushings. It may be awhile, I live in New Orleans. My dealer doesn't have all it's employee's back. I'll report when I have them replaced.

Joe
New Orleans
 

·
Registered
Joined
·
209 Posts
Discussion Starter #4
Where is the bushing? If in the rear does it mean a new rear? Since I have a Maggie I don't know if the dealer will do under warrenty. If I can specify a part they are less likely to say "the clunk is normal". thanks
 

·
Registered
'05 LS6 V Stealth Grey; '14 Z71 SLT Sierra 1500 Stealth Grey
Joined
·
2,821 Posts
Does anyone have the specter bushings? Do they remove the parade clunk? I haden't herd the noise since I had a new rear put in 350 miles ago, now I herd it backing up last night. I'm not too thrilled with the "fix" from caddy and wanted to know about performance, and price. Anyone that can assist, thanks in advance.
 

·
Registered
Joined
·
590 Posts
ahahnu said:
Does anyone have the specter bushings? Do they remove the parade clunk? I haden't herd the noise since I had a new rear put in 350 miles ago, now I herd it backing up last night. I'm not too thrilled with the "fix" from caddy and wanted to know about performance, and price. Anyone that can assist, thanks in advance.
Different issues: the rearend, mounts, and assocaited bushings are all about the clunk and whine... the GM and Specter bushings and/or spacers are about wheelhop.

Thusfar, no matter the fix, the clunk seems to reappear. Mine is getting annoying again, slowly but surely, after the rear-end and bushing was replaced. Not just annoying sound, but 'clunky' driving... perhaps the mount has broken again. :thepan:
 

·
See you in the funny papers
04 CTS-V, 05 STS, 07 SRX- All sold :(
Joined
·
26,239 Posts
The bolts for the rear cradle bushings call for a ridiculous amount of torque, and they always seem to work loose over time. Tighten them with a torque wrench and breaker bar and it'll be gone.
 
1 - 8 of 8 Posts
Top