Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
This morning on the way to work i stopped at a light and my abs and brake light came on.. took rhe truck has the brakes checked brakes seem to be ok.. tech said it could be the abs system. pep boys tech.. anybody have any ideas as to what it could be. Brakes were still good all the way around rotors r ok.. not sure what it could be.. T.I.A.
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
Get the codes pulled

The ebcm(electronic brake control module) controls this and will light both warning lights if there is a issue that disables the system
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Do i have to go to dealer to get them pulled?? Went to pepboys yesterday but they didnt tell me anything.. :angry:
 

·
Registered
2005 Escalade ESV, White Diamond Pearl
Joined
·
342 Posts
Mine either. But my OTC told me what I needed to know when I was getting the ABS and T/C lights.

----------

And it cost me about $100. The same as a dealer would have charged me to read the codes one time.
 

·
Registered
Escalade ESV
Joined
·
2 Posts
Hey guys. Anyone found out how to get rid of the abs lights?
I have 07 esv and lights are on abs and traction control stabilitrak.
I changed front baring assembly with sensor.
Didn't had any codes to clear?!
Anyone know what do I need to do here.
?
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
shobster said:
Hey guys. Anyone found out how to get rid of the abs lights? I have 07 esv and lights are on abs and traction control stabilitrak. I changed front baring assembly with sensor. Didn't had any codes to clear?! Anyone know what do I need to do here. ?
Did you check the history codes?

Sometimes a issue will throw a code then it will not show back up right away so the code goes in history

The only way to get rid of the lights is to either cover or disconnect them as removal of the ebcm will cause the lights to stay on all the time while the truck is running
 

·
Registered
2003 deville
Joined
·
604 Posts
I had those lights come on after crossing railroad tracks, code was something to the effect of LR tire speed high. I went the easiest route and cleaned and put dielectric grease on the plug from the abs sensor to the harness by the tire. Several months later the other rear and same fix, has now been over a year no problems. Worth a try compared to replacing any parts
 
1 - 10 of 10 Posts
Top