Cadillac Owners Forum banner
1 - 6 of 6 Posts

·
Registered
1990 Seville
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 1990 cadillac seville and my dash and my thermo display went out.. I'm not talking about the interior lighting , it's the digital display so I have no speed, fuel, or climate control display

I have a 1990 cadillac seville and one day about a week ago I hopped in my car started it and noticed my digital display on my dash and climate control completely went blank.. I check fuses was all good so hoe do I fix this
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
21,509 Posts
I have a 1990 cadillac seville and my dash and my thermo display went out.. I'm not talking about the interior lighting , it's the digital display so I have no speed, fuel, or climate control display,
find and fix the short FIRST -
the problems might all be related
 

·
Registered
1990 Seville
Joined
·
3 Posts
Discussion Starter · #3 ·
it's jest that ever since I got the car, something has been going out in my car after another, after another and everything literally is new from the transmission to the wheels and tires r new and including the water pump is alt.stsrter,ign.and tumblers,map sensors,catylitic converter jest to name a few.. I do have a hater that I believe that he's the one sabotaging my car on most of my car issues...none the less ur guess guess is as good as mine wgere that short is and if I didn't have so much .money in it, I would sell it to get my money I put in and get something that's not do much as a gas hog.. but for the year with only 96,000,00 original miles I'm thinking of rebuilding the engine as for preventive maintenance...I apologise or my emotional outburst..
 

·
Registered
2011 CTS4 Coupe, 2014 ELR, 2018 XT5 AWD
Joined
·
1,294 Posts
Check the instrument panel dimmer control and make sure it hasn't bee turned all the way down.
 

·
Registered
02 Seville, 04 SRX (sold), 96 Eldorado (sold), 99 DeVille (sold)
Joined
·
1,399 Posts
I found that my 2002 Seville did the same thing. Even though the battery would start the car, it would do that.

The battery had died, I charged it all the way and could start without a jump. Still lost instruments and HVAC. However, when I attached the battery charger and started it, everything is normal. Give that a try. You'll still need to find what is draining it.
 

·
Registered
1990 Seville
Joined
·
3 Posts
Discussion Starter · #6 ·
I found that my 2002 Seville did the same thing. Even though the battery would start the car, it would do that.

The battery had died, I charged it all the way and could start without a jump. Still lost instruments and HVAC. However, when I attached the battery charger and started it, everything is normal. Give that a try. You'll still need to find what is draining it.
The car has not wen back to normal
 
1 - 6 of 6 Posts
Top