Cadillac Owners Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey!

Ive got this unusual problem with my Deville that is when i first start it when its cold it runs and revs as normal.

But after 10-15 minutes it idles a bit rougher and goes really rough when i press down the gas peddal.

It just goes rougher and rougher until it stalls on idles.

Still the same when i start it up again But if i wait a couple of hours its normal again for about 15min.

Ive changed spark plugs, spark wires and the spark coil.

Ive also tried with my buddys Holley carburetor but it was the same problem.

Any ideas and suggestions are welcome.

Excuse my bad english.
 

· Registered
95 FWB 81SDV 96 FWB 94 Fleetwood
Joined
·
1,910 Posts
The first thing I would check would be mechanical timing weights and springs in the distributor. Make sure they are not frozen or broken. If you set the timing with them stuck it will run like $hit.
 

· Administrator
2002 F55 STS, 2014 Explorer XLT, F-150
Joined
·
79,967 Posts
Over time distributor points transfer metal due to sparking (which the capacitor ["condenser"] controls to some degree). One point develops a pit, the other develops a small hump. That causes the gap to change.

The best solution is a new set of points and capacitor every 5,000 miles or so. Second best is a points file.



Actually, the BEST solution is to install a Pertronix Ignitor - a solid-state ignition trigger. No more points.

 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top