Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2001 Deville
Joined
·
61 Posts
Discussion Starter #1
I pressure wash my engine started shaking and loosing power when i start it up when it warms up its good its only when i start it after a minute its goo any idea wat it might be
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,260 Posts
Re: cadillac deville 2001

I pressure wash my engine started shaking and loosing power when i start it up when it warms up its good its only when i start it after a minute its goo any idea wat it might be
-----------------------------
probably water around the spark plugs -

remove the front coil -
see if the boots/plugs are wet -

oh - and don't do that again -
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,436 Posts
.............. and the intake valley is probably full of water, too - the starter motor is down in there and the valley is wide open at both ends.

NEVER pressure wash a Northstar.

Rags, brushes, spray bottle, patience, strong back and beerz.

You're very, very, very lucky that you don't have some really expensive water damage in the engine compartment. Cross your fingers.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
Re: cadillac deville 2001

-----------------------------
probably water around the spark plugs -

remove the front coil -
see if the boots/plugs are wet -
:yeah: I agree. Pull and dry out the ignition cassettes. (Maybe you might get away with spraying them with WD40)
 

·
Registered
1996 Cadillac Deville
Joined
·
127 Posts
Pressure washed??? Damn!!! :holycrap: You, Sir, are a very brave man...

I've been cleaning mine with just spraying Purple Power here and there to get the stuff out and still been pretty hesitant to spray even that on some spots. :lol:

But, yeah, hopefully yours will be okay once everything dries up.
 
1 - 5 of 5 Posts
Top