Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Cadillac
Joined
·
244 Posts
Discussion Starter #1
So I was on my way to school yesterday, when I noticed my "Check Engine" light flashing when I would accelerate. So I attended my classes, and as I was leaving I checked to see if it was still doing this, and it was. When I would accelerate, it would feel shaky and sluggish. So I called OnStar and they did a diagnostic report which said cylinder 2 was misfiring. They sent out a roadside assistance guy, and he confirmed this. He said it was a bad coil, and easy to fix since it was cylinder 2, but he didn't have one on him. He said it was cool to drive to the dealership as long as I eased on the gas slowly, so I did. It flashed again a few times even in cruise control while going slightly uphill. They said it's quite uncommon for such a new car 2008 DI with only 19,000 miles. This is the second time I've had to take my car in for engine troubles, and I'm a little bit worried. Has anyone else had a similar experience?
 

·
Registered
09 CTS DI FE3
Joined
·
416 Posts
So I was on my way to school yesterday, when I noticed my "Check Engine" light flashing when I would accelerate. So I attended my classes, and as I was leaving I checked to see if it was still doing this, and it was. When I would accelerate, it would feel shaky and sluggish. So I called OnStar and they did a diagnostic report which said cylinder 2 was misfiring. They sent out a roadside assistance guy, and he confirmed this. He said it was a bad coil, and easy to fix since it was cylinder 2, but he didn't have one on him. He said it was cool to drive to the dealership as long as I eased on the gas slowly, so I did. It flashed again a few times even in cruise control while going slightly uphill. They said it's quite uncommon for such a new car 2008 DI with only 19,000 miles. This is the second time I've had to take my car in for engine troubles, and I'm a little bit worried. Has anyone else had a similar experience?
I haven't had any issues with my engine other than a slightly rough idle sometimes and what seems to be a slight hesitation at speed occasionally. Other than that it's perfect. I'm not crazy about those issues, but since I don't know a lot about this engine I'm not sure how much of it is normal. When I give it gas, it takes off so I'm happy with that.
 
1 - 3 of 3 Posts
Top