Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
2004 srx
Joined
·
6 Posts
Discussion Starter #1
04 srx awd v6 - i have a clicking noise coming from the driver side front while the wheel is turned slightly to the passanger side. it gets louder the faster the speed and the harder the curve. it even does it while going straight and turning the wheel just far enough to put pressure on the steering system. it does not do it while turning a corner at lower speeds. i have checked brakes for loose parts and there is no play in the wheel bearing. Would the noise im hearing possibly be coming from the cv joints. i tried to feel for play in them but there wasnt anything i could feel. there is no vibrations to speak of just the noise but having my 3 year old in the car daily it concerns me.

if anyone could help me with this i would truely appreciate it.
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
CV joint or wheel bearing and it might just be the other side; front end noises are weird that way. You sure you're not also on the brakes at the same time, stone caught in the caliper?
 

·
Registered
2004 SRX V6 AWD
Joined
·
687 Posts
Don't have any brilliant insight on which part it is, but these bearing type failures tend to progress fairly slowly. So unless you're going on a lengthy trip, I wouldn't worry about getting stranded.
 

·
Registered
NONE
Joined
·
144 Posts
I have trouble with clearance on the brake rotors heat shield. One or twice a year I have to bend the shield away from the rotors due to clicking and rubbing. The sound only shows up when loading the vehicle one way or another during a turn.
 

·
Registered
2004 srx
Joined
·
6 Posts
Discussion Starter #5
I am having a similar issue except I have already replaced the CV shaft on both sides in the front. I did find a very worn out tie rod on the side the clicking was coming from...I found that after I replaced the shaft. After my test drive it is still making the same noise. everything else is tight and good. Could a tierod cause this clicking.
 

·
Registered
98 DeVille, 97 DeVille d'Elegance
Joined
·
7,345 Posts
I am having a similar issue except I have already replaced the CV shaft on both sides in the front. I did find a very worn out tie rod on the side the clicking was coming from...I found that after I replaced the shaft. After my test drive it is still making the same noise. everything else is tight and good. Could a tierod cause this clicking.
Tierods don't click so no its not the issue. Has to be a rotating part.
 

·
Registered
SRX 07 V8
Joined
·
230 Posts
I have trouble with clearance on the brake rotors heat shield. One or twice a year I have to bend the shield away from the rotors due to clicking and rubbing. The sound only shows up when loading the vehicle one way or another during a turn.
Read post "sounds like a cow bell under my car" from orandaberg, turned out it was the shield
 

·
Registered
2004 srx
Joined
·
6 Posts
Discussion Starter #8
I just replaced the tie rod and the clicking quit I didn't think a tie rod would do that either but it did just a thought for others to check out having similar issues
 
1 - 8 of 8 Posts
Top