Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I have a 2015 ATS 2.0L. My CUE screen is doing this thing where all of a sudden, it will act like someone is pressing the preset radio station in the middle of the list. And the row of presets will move back and forth like someone is touching the screen with a shaky finger. It also beeps and provides that haptic "bump" every few seconds like I'm setting a new preset. I've cleaned the screen because I thought maybe there was a smudge that it was picking up as input. When this occurs, I can change the station with the steering wheel button, but the screen is unresponsive. And this only occurs on the radio screen. This behavior does not occur on any other screens, and can last anywhere from a few seconds to a few minutes. It eventually goes away. I had the screen replaced once under warranty, but now I'm out of warranty. Any ideas?
 

·
Registered
2017 ATS Premium Luxury
Joined
·
99 Posts
You need a new screen. Common problem on these cars. If you’re handy, you can DIY for about $50-$150, depending on where you buy your replacement screen. Dealer will charge about $1200 and replace the entire center stack, which really isn’t necessary.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
58 Posts
mpreissner, thanks! I've seen videos of how to replace the screen, and it's actually easier than I thought. I also found a replacement screen for $149 at https://www.germanaudiotech.com/pro...lac-ats-cts-srx-xts-cue-touch-sense-2013-2017. Do you know if that's a good place to get one, or are there better vendors?
I would recommend Cue Screens. I purchased their premium version for $130 and have no complaints, works perfectly. Regardless of the brand you go with, just don't go cheap. Some of the knock-offs lack the proximity sensors.

https://www.cuescreens.com/?gclid=EAIaIQobChMI9fTphtiM5QIVYiCtBh2tKASJEAAYASAAEgIBHfD_BwE
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5

·
Registered
ATS
Joined
·
4 Posts
I have a 2015 ATS 2.0L. My CUE screen is doing this thing where all of a sudden, it will act like someone is pressing the preset radio station in the middle of the list. And the row of presets will move back and forth like someone is touching the screen with a shaky finger. It also beeps and provides that haptic "bump" every few seconds like I'm setting a new preset. I've cleaned the screen because I thought maybe there was a smudge that it was picking up as input. When this occurs, I can change the station with the steering wheel button, but the screen is unresponsive. And this only occurs on the radio screen. This behavior does not occur on any other screens, and can last anywhere from a few seconds to a few minutes. It eventually goes away. I had the screen replaced once under warranty, but now I'm out of warranty. Any ideas?
I have a 2016 2.0 T and have the same problem. I have reported the issue to my dealer, and was unsuccessful in getting the malfunction to happen when I was at the dealer. They seemed to be unware of any problems like this. I'm only about 6K miles from the warranty expiring. Is there any service bulletin on this topic?
 

·
Registered
2013 ATS 3.6L Luxury
Joined
·
337 Posts
There is a TSB for dead spot on CUE and I think another for cracking/delaminating, but I don't think I've seen one for ghost touching. Try to get a video when it's happening.
 

·
Registered
2016 ATS4 2.0T and a bunch of other stuff....
Joined
·
660 Posts
They seemed to be unware of any problems like this.
I love it. Problems to the extent of a class action lawsuit ant they're not aware. My original dealer, after replacing mine, told me "Yes, it will happen again".
 

·
Registered
Joined
·
12 Posts
I have a 15 ATS coupe, and my CUE started doing the exact behavior as the OP. It was very random. I bought a new screen from cuescreens.com. I just installed it last weekend. It took less than an hour, and everything is functioning fine. Hopefully with a screen that has no gel in the middle, this issue is gone forever.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #10
I have a 15 ATS coupe, and my CUE started doing the exact behavior as the OP. It was very random. I bought a new screen from cuescreens.com. I just installed it last weekend. It took less than an hour, and everything is functioning fine. Hopefully with a screen that has no gel in the middle, this issue is gone forever.
itguy, thanks for the info! Which one did you buy, the premium or basic? If you could, give us an update and let us know how it's doing long-term.
 

·
Registered
Joined
·
58 Posts
itguy, thanks for the info! Which one did you buy, the premium or basic? If you could, give us an update and let us know how it's doing long-term.
I purchased the premium ($130) screen from cuescreens about half a year ago. My install took probably 2 hours, but I was taking it slow and doing things carefully. So far, zero issues and zero complaints. Everything is working perfectly.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #12
I purchased the premium ($130) screen from cuescreens about half a year ago. My install took probably 2 hours, but I was taking it slow and doing things carefully. So far, zero issues and zero complaints. Everything is working perfectly.
Good to know! My first screen acted up within the first two years of ownership. The current GM replacement started about another two years later. It's pretty sad that we apparently can buy better screens for $130 than GM can provide. Thanks for the update!
 
1 - 12 of 12 Posts
Top