Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 9 of 9 Posts

·
Registered
Cadillac
Joined
·
16 Posts
Discussion Starter · #1 ·
Hey everyone, I have a 2003 cts with the 3.2 motor, like most people I have a problem with my throttle body and can not drive my car. Its been well over 5 months and the part is still on back order from the company and GM has done nothing to help me out. I was wondering if someone knew if I was to purchase a throttle body and manifold off of a 2004 and up cts would I be able to swap it out and have my car running. Any help is much appreciated. Thanks in advance.
 

·
Registered
2003 CTS "Ebony Maria" 2005 Cadillac STS "Grace"
Joined
·
6,414 Posts
i am almost certain it will not work if you swap out the manifolds and the TB...

CT Essence...the TBs in the 03s for some reason tend to throw crazy codes and then basically give the engine reduced power, nobody has ever found out the cause

to the OP...try going on www.car-part.com and getting a TB off of a wrecked car, might be your best bet
 

·
Registered
Cadillac
Joined
·
16 Posts
Discussion Starter · #5 ·
i ordered mine straight from a Cadillac dealer and have been dealing with the company corp. The issue with my car is that i have 5 codes and the car does not drive.It shuts of while i drive, gives me engine reduced and motor shakes. i replaced it with a used one already and still is having the same problem again. i checked out that website before and not much luck finding one there. thanks for u help though
 

·
Registered
Cadillac
Joined
·
16 Posts
Discussion Starter · #6 ·
another thing is i had this same problem before and replaced the throttle body with a used one and it worked for about 3 months and now its happened again
 

·
Registered
Joined
·
465 Posts
allday,

A lot of folks have reported the identical problem, specialy with the 2003/3.2L CTS model.

Of all the info gathered, it appears that the problem may lie with a poor TB/TPS electrical module connection. If and when the subject terminals get dirty, loss of conductivity (low voltage) takes place. When this occurs it sends a message to the ECM and the vehicle goes into Reduced Power Mode and throws numerous codes associated with the TPS . Another code we usually get when the TB/TPS connection needs to be cleaned, is code 0700. This happens when the tranny starts to shift, and down shift, very hard.

The solution: SIMPLE.

Disconnect the electrical TB/TPS module and spray "Electrical Parts Cleaner" into the male/female terminals of the module. Spray it good. Wait for it to completely dry before reconnecting. Crank it up. Clear the codes. Take her for a spin.

Hope this helps your situation. It's helped many on this forum.
 

·
Registered
2003 Cadillac CTS 3.2L V6
Joined
·
275 Posts
allday have you replaced the crankshaft position sensor? That might solve your problem. Some of the folks w/ an 03 have solved the issue you're having by replacing it. Worth a try and it's only like $60.
 
1 - 9 of 9 Posts
Top