Cadillac Owners Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
So im taking my 07 cts 3.6(i have the extended warranty) to the dealer tomorrow to get checked out but wanted to know if anyone here has experienced anything similar so that i know what to expect from the dealer. So lately my cts seems to sputter sometimes and it seems like its lost power.. Its not time for an oil change and i recently replaced the air filter. When i accelerate it seems to shift fine till its gets to 3rd gear, it sputters a little bit and shakes but if i step down on the gas more it goes away.. Once i get on the freeway it runs ok but still dont feel the full power. I also notice that it seems to run a little bit better when it has a full tank of gas but once its low it acts up the most. Dont know if this makes sense to anyone.. Ive tried using fuel injector cleaner but still the same. Anyone have an idea on what this can be? It just seems to be like in a different gear sometime when it shouldnt be (if that makes sense).. Also my check engine light has not came on..
 

·
Registered
Joined
·
79 Posts
So im taking my 07 cts 3.6(i have the extended warranty) to the dealer tomorrow to get checked out but wanted to know if anyone here has experienced anything similar so that i know what to expect from the dealer. So lately my cts seems to sputter sometimes and it seems like its lost power.. Its not time for an oil change and i recently replaced the air filter. When i accelerate it seems to shift fine till its gets to 3rd gear, it sputters a little bit and shakes but if i step down on the gas more it goes away.. Once i get on the freeway it runs ok but still dont feel the full power. I also notice that it seems to run a little bit better when it has a full tank of gas but once its low it acts up the most. Dont know if this makes sense to anyone.. Ive tried using fuel injector cleaner but still the same. Anyone have an idea on what this can be? It just seems to be like in a different gear sometime when it shouldnt be (if that makes sense).. Also my check engine light has not came on..
If i were you i would check the fuel filter and get your fuel pressure checked to make sure both your pumps are good. If it is only when your getting low it could the the cts reservoir pump which is a separate little 2 gallon reservoir fuel tank in these cars on top of the 17gallon tank and the primary pump. So in order to do that you would have to have low gas if you take it in just as a heads up cause then they can check the reservoir tank and pump fill er up a bit and check the primary pump. A bad fuel pump and low fuel pressure will cause loss in power and probably eventually sputtering when that pressure gets low enough as the air to fuel ratio gets ****ed up. Or there is a chance it is blocked/dirty fuel filter.
 
1 - 2 of 2 Posts
Top