Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My cadillac cts 2003 was working great, the key wouldnt come out of the ignition but i would just click the botton on the steering wheel and it would come out without an issue, the problem i am having is that now it turns off, after like 5 -10 minutes the cars voltage goes down from 14 to 12 and it turns off, and after that i try to turn it on and it just does a clicking noice like if the battery it out , after a few cranks it comes back on, so i cant drive it that way, i can even just turn it on and leave it in park and after a few minutes it does the same thing. I have changed the crank shift sensor, the battery, the alternator, can someone please help.
 

·
Registered
67 Deville Convertible, 07 CTS Sport, 06 Envoy
Joined
·
1 Posts
Check your grounds and connections to the starter. You could have corrosion in the ring terminals. Tug on everything, make sure a wire isn't touching an exhaust manifold.
 

·
Registered
Joined
·
15 Posts
I agree with others check your grounds.
Probably a little corrosion, clean and add a little electrical grease to the connections you clean.
 

·
Registered
Joined
·
1 Posts
Probably a relay, since it starts and then cuts off. Just find it and replace it, see what it does after 10 minutes. That's if the voltage you said drops when it begins to shit down, good luck.
 
1 - 6 of 6 Posts
Top