Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
I have a Cadillac CTS 2003. My car will start and drive perfectly fine in the morning. The FIRST time I turn it off , it does not come back on because it seems like it is hot. It does a clicking noise and you can see the timing belt move with every click. All the power inside the car works just not getting any power to ignition obviously. We replaced the radiator already about 2 weeks ago, it was running fine then all the sudden it started this problem again. Please help , I'm ready to just get rid of the thing.
 

·
Registered
2003 CTS
Joined
·
2,336 Posts
when my 03 did that, it actually ended up being the battery. first trip to autozone for a free check, they said battery was good. I had the starter replaced and all was good for about 2 months and it started again.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #3
when my 03 did that, it actually ended up being the battery. first trip to autozone for a free check, they said battery was good. I had the starter replaced and all was good for about 2 months and it started again.
I had my battery read today it said good as well. Should I just replace the battery first.
 

·
Registered
2003 CTS
Joined
·
2,336 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #6
not sure how old your battery is. but you are describing the same as mine did. it would start the first time just fine. I could take a short trip to the store and after running in and returning in about 10 minutes or so, I would get that click that you speak of. actually, I started a thread years ago. check out post 13 and see if this describes your 03.
http://www.cadillacforums.com/forums/cadillac-cts-first-generation-forum-2003/258842-anyone-changed-starter-03-a.html
Thank you so much I watched the video and that's exactly what my car does. I will definitely get a new battery, any brand suggestion? I know some batteries are better than others.
 

·
Registered
2003 CTS
Joined
·
2,336 Posts
i usually go to autozone and pick up the duralast gold 78, pretty sure that's it. the wife is in the car, so I cant be 100 percent.
it is a tight fit, but it will work
 

·
Registered
2005 CTS 3.6 - 165k miles
Joined
·
49 Posts
This is great info. My 05 has been doing this since i got it last april, and today i find out the battery is extremely weak and only holding 29% charge. I will swap the battery and see if it helps.
 
1 - 9 of 9 Posts
Top