Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
2003 CTS
Joined
·
7 Posts
Discussion Starter #1
About a month ago my son was driving his car and it lost all power and shut down and it would not restart at all....just cranks over. We listened for the fuel pump and determined at that time that we could hear no noise from the pump so we replaced it. While we replaced the pump we verified we heard it "pump up". We attached the old pump and were a little disappointed that the old pump powered up also...I guess we were tricked by another part failure and wasted the process of installing a fuel pump. We verified that fuel was getting part the fuel filter, cracked the line plenty loose on the opposite side of tank on the filter and gas poured out heavily. We were told by a mechanic to try a blast of starting fluid through the air valve on the front of the intake and see if that made it come to live. After several blasts there was only one or two small misfires. I also tried starting fluid through the vacuum hose that assists the master cylinder at the connection in the manifold, directly in and it didn't fire either. There is a green cap on the left side of the engine, thinking that should be a test port I tried to see if gas would come out when the key was on, or if while cranking it over if there was pressure. There was no pressure. Taking the plenum of we tested for fuel at what appears to be a test port in the center area and gas only came out, in a heave dose while the car was trying to be started. Thinking the car had a bad pressure regulated and would not get fuel to the injectors, I gave a heavy dose of starting fluid down the intake runners and there was no sign of detonation at all.

I am lost for what the problem may be. This is our only form of transportation right now and I need help. Someone please give me an idea on what I should change. I think it isn't getting spark but cant figure out how to verify that except for tearing the whole top end apart. I am a disabled veteran and live on a small pension and can't afford a mechanic. Someone told me maybe a sensor, crank position sensor??? My son did have a random light come on once in a while for the airbag. It would go off and stay off for a long while but the car did run at all times. He said he was just driving, slowed down for a stop sign and it lost all power and wouldn't restart.
 

Attachments

·
Registered
2003 CTS
Joined
·
7 Posts
Discussion Starter #3
Does anyone know if a failure of the crank position sensor would be a result of an absolute no start condition? I hate to order one and be out $50.00. Also location? Time for installation and any particulars associated?
 

·
Registered
2003 CTS
Joined
·
147 Posts
Yes... A bad crankshaft position censor wont allow car to start. It will just crank but will not fire. Doesn't relay proper firing position ( timing of spark)
 

·
Registered
2003 CTS 1SC Luxury Sport
Joined
·
1,017 Posts
Down below on drivers side of the engine block, just above the oil filter housing.
 

·
Registered
2003 CTS
Joined
·
7 Posts
Discussion Starter #7
Put the top back together. Did not check for spark due to having a scan toolbrought over. Codes pulled out:

P0123 Throttle pedal sensor,
P0222 Throttle pedal sensor,
P0343 Camshaft position sensor.

Was advised by mechanic friend to clear codes and try to start several times, did as advised. On the first crank of the ignition, there was one pop like it tried to fire and then it just cranked over several times. We tried at least a dozen times and reconnected the scan tool and got no codes. I can't invest in a cam position sensor if it is not 100% sure. We now have the battery charging to bring it back up to full voltage and will try several more times and see if a code comes up. Anyone....Please advise!

----------

Cranked the car over after letting the battery charge for a bit and the P0343 Camshaft Position Sensor code is back in the computer. Still did not verify spark. Ordered the Camshaft Position Sensor.....did I make a mistake?
 

·
Registered
2005 Cadillac Escalade
Joined
·
1,177 Posts
Friends car takes longer to crank and start. Also almost bought a new fuel pump. Most recent he was on the parkway and the car died he managed to pull over put it in drive and the car started. Pulled codes p0341 and p0343 just bought a camshaft position sensor will be here Wednesday will let you know how it works out. If yours isn't starting period it should be the CRANKshaft but why it's pulling cam shaft is beyond me. Buy the parts online save money and if it's the wrong part most companies take it back
 

·
Registered
2005 Cadillac Escalade
Joined
·
1,177 Posts
Just wanted to post and let everyone know it fixed the problem. Also bought the crankshaft position sensor and put it in my garage changing that soon I think these sensors go hand in hand
 

·
Registered
2005 Cadillac Escalade
Joined
·
1,177 Posts
If your car starts but takes longer to kick over and sometimes dies on the highway, camshaft position sensor. If your car dies and or DOESNT start you need crankshaft position sensor. Cam is easy to replace its ontop of the motor. Crank shaft on the 3.2 is by the oil filter can . Little tricky to get to but it's doable I haven't done it yet but there's a write up

http://www.cadillacforums.com/forums/cadillac-cts-first-generation-forum-2003/138609-2003-cts-crankshaft-position-sensor.html#/forumsite/20562/topics/138609
 
1 - 12 of 12 Posts
Top