Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
I just dropped 6 GM coolant tabs in my upper rad hose, now the temperture goes up on every red light and higher temperture than before, what's going on?
 

·
Registered
2008 SRX-V8, 1991 Eldorado
Joined
·
1,543 Posts
luc1 said:
I just dropped 6 GM coolant tabs in my upper rad hose, now the temperture goes up on every red light and higher temperture than before, what's going on?
For one...the tabs are best placed into the lower hose, but the number of tabs has nothing to do with your temperature problem unless you plugged the upper hose with tabs or blocked the thermostat.

Boiling the front tires from one stop sign to the other might have something to do with temperature...*LOL
 

·
Registered
1999 STS - diamond white
Joined
·
5,229 Posts
It doesn't matter which hose you put them in - just not in the reservoir. What else did you do? Is the coolant level correct? You may have air in the system. That's all I can come up with. Keep us updated.
 

·
Registered
2007 SRX
Joined
·
347 Posts
Why not in the resevoir?? I have seen this mentioned before but it is how GM recommends it be done.
I ground mine up, disolved them in some water and poured the resulting mixture into the resevoir.
 

·
Registered
13 Challenger RT, 11 CTS Coupe Premium, 94 Eldorado (RIP)
Joined
·
1,306 Posts
If you put them in the resevoir and they were ground up, they will get through the system, just not as efficiently as in the lower hose.

Did you recently do some work to the cooling system or were you just dropping some tabs in?

You have a 98 ETC, correct?
 

·
Registered
Joined
·
32 Posts
Discussion Starter #7 (Edited)
98 ETC yes, I changed the coolant about a week ago and everything was good, the temperture went up only a few times and it cooled itself down quickly. Now I was driving normaly with no heavy acceleration and the temperture rises on every red light I hit, could something be plugged? should I push her a bit to get the tabs through the system?

Coolant was topped off after the tabs were dropped and the thermostat was also changed a few weeks ago.
 

·
Registered
1999 STS - diamond white
Joined
·
5,229 Posts
luc1 said:
Coolant was topped off after the tabs were dropped and the thermostat was also changed a few weeks ago.
Ahh, that was missing in your first post. The new thermostat may be bad. Maybe only partially opening. That would cause overheating if it isn't opening correctly.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,778 Posts
Check the purge line to be sure it did not get clogged.
 

·
Registered
13 Challenger RT, 11 CTS Coupe Premium, 94 Eldorado (RIP)
Joined
·
1,306 Posts
Check your purge line first like Ranger said. To back up EcSTSatic, I have had brand new stats fail to open at the correct temp. It happens.
 
1 - 10 of 10 Posts
Top