Cadillac Owners Forum banner

1 - 16 of 16 Posts

·
Registered
Cadillac
Joined
·
8 Posts
Discussion Starter #1
i changed the coolant today and now think i have a problem. i drained the coolant with the car cold. i refilled with a bottle of the bars leak stuff (not the pellets, the other bars leak) and a 50/50 dexcool. now when i run the car it gets to the notch past half way before the thermostat opens and it cools down. (i know the stat is opening bec the lower hose gets hot wheras it was cool before) problem is before the new coolant the needle never got past half way at all. what gives? did i miss something? HELP!!
 

·
Registered
1926 Model T street rod, 2000 Jaguar XJ8, 1999 Corvette.
Joined
·
6,738 Posts
The system is not completely filled. What year and type of Cad? its not in your profile.
 

·
Registered
2013 XTS
Joined
·
2,087 Posts
I agree air in system I let mine run for a long time watch the reserve tank for no more bubbles then you should be good to go.
 

·
Registered
94 Eldorado, and a 99 ETC
Joined
·
3,887 Posts
When you fill it up with coolant, it's a good idea to squeeze the upper radiator hose to help get the bubbles out.
 

·
Super Moderator
2010 DTS
Joined
·
87,543 Posts
Assuming that the purge line is clear, all you have to do after a coolant change is rev the engine to 3000 - 4000 RPM a few times. That will purge any air in the system (cap on or off).
 

·
Registered
Cadillac
Joined
·
24 Posts
hey im over heating in my deville getting temps in the 215-222 range and at that temp the oil light flashes it today even told me to shut off the car im using mobil 1 synthetic --- got a recent leak cant tell if it's dex cool or oil though because i dont lose much more oil than usual i've seen many post on head gaskets and carbon build ups but i am lost
 

·
Registered
95 Fleetwood Brougham / 01 DTS / 11 CTS Lux / 11 DTS Platinum
Joined
·
7,085 Posts
I had the same situation after doing the coolant in my DTS. After about 6 months the system must have burped itself. I started the car one day and the low coolant level warning was on. I topped it off and it's been fine since.

Did you purge the system or did you just drain? Flushing and draining are two separate issues.

I do think I have a very very small leak on the crossover but it's not related to this.
 

·
Registered
94 Eldorado, and a 99 ETC
Joined
·
3,887 Posts
hey im over heating in my deville getting temps in the 215-222 range and at that temp the oil light flashes it today even told me to shut off the car im using mobil 1 synthetic --- got a recent leak cant tell if it's dex cool or oil though because i dont lose much more oil than usual i've seen many post on head gaskets and carbon build ups but i am lost
215-222 is completely normal. Around 240 means there's a problem.

Your oil pressure sensor is going bad. Change it to get rid of the oil light.
But before you do anything, check the oil level and codes to make sure that I'm not wrong.
 

·
Registered
Sedan de Ville, CTS
Joined
·
4,764 Posts
Heat in upper hose tells you if therm is open. Right???

Water comes up to top of engine; stat opens, and water fills radiator. Water then goes thru lower hose into engine.
 

·
Registered
94 Eldorado, and a 99 ETC
Joined
·
3,887 Posts
Heat in upper hose tells you if therm is open. Right???

Water comes up to top of engine; stat opens, and water fills radiator. Water then goes thru lower hose into engine.
Lower hose is more accurate.... but good luck feeling it with the fans turning on without warning.

The pump will suck coolant out of the lower hose, so it is the last hose to heat up because it has to wait for coolant to flow from the upper hose through the radiator and into the lower hose before it warms up.
 

·
Registered
Cadillac
Joined
·
24 Posts
Krashed989
Caddyholic

Cadillac(s): 94 Eldorado, and a totaled z rated STS Join Date: Sep 2004
Age: 19
Posts: 2,516



Re: coolant flush...now a problem...

--------------------------------------------------------------------------------

Quote:
Originally Posted by pops97deville
hey im over heating in my deville getting temps in the 215-222 range and at that temp the oil light flashes it today even told me to shut off the car im using mobil 1 synthetic --- got a recent leak cant tell if it's dex cool or oil though because i dont lose much more oil than usual i've seen many post on head gaskets and carbon build ups but i am lost

215-222 is completely normal. Around 240 means there's a problem.

Your oil pressure sensor is going bad. Change it to get rid of the oil light.
But before you do anything, check the oil level and codes to make sure that I'm not wrong.
__________________
~Allen


it used to never get that hot though it would stay at around 192-199 when it was hot out and a BONUS my outside temp is tripping too it going form normal to readings of a 127 degrees F
 
1 - 16 of 16 Posts
Top