Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
2003 DTS
'03 Deville DTS
Joined
·
292 Posts
Discussion Starter #1
Greetings once again fellow Cadillac lovers/sufferers.

I started my car today and it starts making a tapping noise. Not like a valve tap though,more like something rotating and hitting something or something loose inside something rotating. At first it was constant,then it went to tap, tap, tap, silence then repeat. Then it went away to be replaced by a very weird noise that only happens when I turn off the A/C. Sounds like a plate of gravel getting bounced around. Once the a/c clutch kicks in it goes away, I am getting a whine that seems louder than normal though. This whine disappears when the whatchamacallit kicks in at 41mph. So far I'm thinking the a/c compressor pulley bearings or shaft bearings are shot. Then I check for codes and I get PCM-P1611- Loss of CVRTD Serial Data and TCS-U1056- Loss of CVRSS comm. So now I'm back to huh? Which brings me here to beseech all of you for an explanation if you can of how these codes which would lead me so far to suspect a bad connection/wire/ground somewhere to what I'm hearing when the car runs. If your wondering,yes the a/c works fine;frosty cold.

DJSG3
 

·
Registered
1996 Deville (sold), 2000 Mustang GT
Joined
·
1,300 Posts
A bad ground or dying battery will definetly throw some codes, whether or not its related to your noise is questionable. The easiest way to find the noise is with a stethascope, it'll determine what part is making the noise fairly quickly. If it is you a/c compressor pulley/bearing it will make a lot of bad noises before it seizes and melts your serpentine belt. BTW changing out that a/c compressor is a pain in the a**
 

·
Super Moderator
2010 DTS
Joined
·
87,866 Posts
Put a 1/2" drive breaker bar in the square hole on the back side of the serpentine belt tensioner and use it as a lever to release the belt tension just enough to let the belt slip. That will stop the accessories from spinning. If the noise goes away, it is one of the accessories (probably the A/C clutch or compressor).
 

·
2003 DTS
'03 Deville DTS
Joined
·
292 Posts
Discussion Starter #4
Yeah its the A/C compressor all right. I just don't understand why it would cause the suspension errors to register. Too much drag on the belt maybe?

BTW changing out that a/c compressor is a pain in the a**
A pain in the butt to change? Naw say it aint true. After emptying the system and draining the oil, I just have to move five or ten things out of the way with I'll bet a whopping half inch clearance at any given time. Then fight the beasty out of its lair. How could that be a pain in the butt? :)

DJSG3
 

·
2003 DTS
'03 Deville DTS
Joined
·
292 Posts
Discussion Starter #5
Final results. It wasn't a hard job at all. A little time consuming but for the way this car is put together damn easy to do. I used the service manual instructions as well as the ones found on this forum. Differences being - the manual told me to remove the oil cooler lines from the oil filter adapter, the instructions on here don't say to do that and so I'm sitting there scratching my head trying to figure what the heck the manual is talking about (no cooler line that I could see) so I said okay and just unbolted the oil filter adapter. Suddenly I had lots of room to get at that suction pipe bolt. Which I removed before loosening the mounting bolts. Total time was about four hours,could have been quicker if I knew what was what from the get go, had the alternator halfway unbolted at one point before realizing that. Got the system drained,vacuumed & recharged for $60 (had to buy half a pound of r134) Compressor I got for $220 (remanufactured) PAG Oil & O-rings less than $20.
No special tools needed. One socket wrench,a couple of extensions for it. A 10mm & 15mm socket, one 10mm box wrench, a phillips screwdriver and for leverage when trying to break the bolts hold I used the jack handle from the trunk. So $300 and lets say 5 hours total down time and I'm a happy camper. Still haven't figured out why the suspension codes showed up but their gone and haven't returned. Gosh I just can't wait to see what goes wrong next!

DJSG3
 
1 - 5 of 5 Posts
Top