Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
2005 Black CTS-V
Joined
·
500 Posts
Discussion Starter #1
Well, I did a search and didn't come up w/ anything solid..

Here's the problem, when I first get in the car and press the clutch to start, EVERY time I release the clutch petal, it pops once it reaches the top. Now if I'm shifting gears through traffic, it doesn't pop but maybe once ever 3-4 shifts.. I can't hear it if the radio is loud enough, but if its dead quiet in the car, here goes to POP noise from the petal.

I located the noise comming from the master cyld... Do you think it should be cover under the warranty for the noise?

Thanks! :highfive:
 

·
Registered
2005 Cadillac CTS-V
Joined
·
800 Posts
Ya, unless you modified it in someway....it'll be covered...don't try and be a mechanic and point things out...jsut say you here a noise when you release the clutch pedal.
LOL at some dealerships you better point out the problem or be prepared to have them fix something thats not broken and go back in another day. :thumbsup:
 

·
Registered
2005 Black CTS-V
Joined
·
500 Posts
Discussion Starter #4
All I did was pull the lower panel off that's next to the petals to take a look.. I pressed the petal down a few times and narrowed the noise down to the master cylinder.. I could play stupid, but I bet they'll come back and say they hear nothing. :rolleyes:

It looks like a beeeoch to change, too!
 

·
See you in the funny papers
04 CTS-V, 05 STS, 07 SRX- All sold :(
Joined
·
26,239 Posts
Try spraying a little lubricant on the clutch actuation lever that goes through the firewall. I had this same problem on another car, and that fixed it. While you're there, spray some on the pedal springs too.
 

·
Registered
2005 Black CTS-V
Joined
·
500 Posts
Discussion Starter #6
Try spraying a little lubricant on the clutch actuation lever that goes through the firewall. I had this same problem on another car, and that fixed it. While you're there, spray some on the pedal springs too.
WD40 the springs a few weeks ago.. Still did it. I got back under there and sprayed the little silver rod thing.. Still does it. :bigroll:
 
1 - 6 of 6 Posts
Top