Cadillac Owners Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
2007 sts Cadillac installed new battery and clock failed. Adjustment screen for clock comes up but won't function. Normal screen shows clock as "--.--". Help, this causes nav system not to load for 15 to 20 min.
 

·
Registered
08 STS-4 N* 1SG, 08 DTS Luxury II, 04 Bonneville GXP N*
Joined
·
3,206 Posts
2007 sts Cadillac installed new battery and clock failed. Adjustment screen for clock comes up but won't function. Normal screen shows clock as "--.--". Help, this causes nav system not to load for 15 to 20 min.
Welcome to the forum. Here is 37 pages of conversation you can browse relating to this very same issue.
 

·
Registered
2011 DTS Premium
Joined
·
14 Posts
2007 sts Cadillac installed new battery and clock failed. Adjustment screen for clock comes up but won't function. Normal screen shows clock as "--.--". Help, this causes nav system not to load for 15 to 20 min.
I put a new battery in my 2011 DTS yesterday, same issue now with the clock and the gps has a red line thru it. Tried searching for a fix but no luck. Anyone with a solution?
 

·
Registered
2011 DTS Premium
Joined
·
14 Posts
I put a new battery in my 2011 DTS yesterday, same issue now with the clock and the gps has a red line thru it. Tried searching for a fix but no luck. Anyone with a solution?
I have since found more recent replies, sorry to beat a dead horse guys ; )
 

·
Registered
2011 DTS Premium
Joined
·
14 Posts
I found this YouTube video, gave it a try and it worked! Nav and clock are now working 🙏🏻😄
Hope this can help someone else too.

 

·
Registered
2007 STS4
Joined
·
18 Posts
I tried this on my 2007 STS but it does not have the same function buttons, there is no specific menu button that lets you hold down a spot in the bottom of the screen.
 

·
Registered
96 STS; 09 STS4 N* Platinum w/1SG & PCZ
Joined
·
181 Posts
Rob.o,

There is a place to hold your finger, but the "program" that come up does not provide any way to fix the current problem with the STS.

BronzeDTS, What exactly did you do while in the "secret screen" that fixed your problem?
 

·
Registered
2011 DTS Premium
Joined
·
14 Posts
Rob.o,

There is a place to hold your finger, but the "program" that come up does not provide any way to fix the current problem with the STS.

BronzeDTS, What exactly did you do while in the "secret screen" that fixed your problem?
Once you put in the code, you go thru to the second page of settings, to clock settings, you are able to set the year date and time, then back out and done. This also fixed the gps red line.
There’s wasn’t a specific button to access the secret screen, just the bottom left of the screen.
 

·
Registered
2011 DTS Premium
Joined
·
14 Posts
Once you put in the code, you go thru to the second page of settings, to clock settings, you are able to set the year date and time, then back out and done. This also fixed the gps red line.
There’s wasn’t a specific button to access the secret screen, just the bottom left of the screen.
This video shows more detail of the procedure I used.
 

·
Registered
2007 STS4
Joined
·
18 Posts
Can you tell me your steps you went through to get to the code and what is the year of your car because mine does not have a menu button, it has the config button and I cannot find a way to get to the code.
 

·
Registered
2011 DTS Premium
Joined
·
14 Posts
I got the code from the video and followed what they said to do, mine is a 2011, but they said it would work on other years. What year is yours?
 

·
Registered
2007 STS4
Joined
·
18 Posts
It does track where I am to some degree but is not accurate, the GPS button has a line through it.
 

·
Registered
2011 DTS Premium
Joined
·
14 Posts
It does track where I am to some degree but is not accurate, the GPS button has a line through it.
That’s exactly what mine did, there has to be a hack for you as well. Try looking on YouTube and search for your vehicles nav secret settings. I did see on for a CTS that may work for yours. Best of luck! 😀
 

·
Registered
06 STS-V & 06 STS 4 (sold 2016)
Joined
·
2,713 Posts
No offense, but you guys are wasting your time. This fix does not exist for the STS. The hidden menus have already been explored.
 

·
Registered
08 STS-4 N* 1SG, 08 DTS Luxury II, 04 Bonneville GXP N*
Joined
·
3,206 Posts
Agreed. The STS radio is entirely different and does not use the same firmware.

This appears to be the procedure outlined in GM's bulletin #PIT5652E. What has been omitted from this video is a line directly from the bulletin that states "If this concern is encountered on Pontiac Grand Prix, Cadillac STS or Corvette radios with RPOs U3U, U3Z, URB, US4 or YQ4, the procedure in this PI does not apply. Engineering and supplier are currently investigating this issue on those vehicles and radios."
 

·
Registered
2007 STS-4, 1949 60S Fleetwood
Joined
·
25 Posts
I have a 2007 STS and the same thing happened to me on December 30, 2019 when I changed the battery.
The CLOCK JUST CAME BACK ON an hour ago.!!!! YEAH!!!!
The car thinks it's August 20, 2000, but the clock is working.
I don't care about the date.
Just wanted to share this!!!
 
1 - 20 of 21 Posts
Top