Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter #1
I just replaced the blower motor in my 91 DeVille sedan with one from a junk yard. The guy said that the one that he gave me from a early 90's Eldorado would work. I have read somewhere that you do not want to mix models. Now my heat will not go above 78 without going back down to 75 and showing a C instead of the climate and gas info. Has this ever happened to you any of you guys? Is it because i got the motor from a Eldorado?
 

·
Registered
Joined
·
18 Posts
NCGNETO90 -

I have a similar problem to yours, however I did not change anything (yet) and still got this reading... Was wondering if I may have fried my BCM ... since that is what controls the ECC? Anyhow... here is my situation...

I have a 1989 DeVille FWD that I put it in storage 1 1/2 years ago. When I took it out two weeks ago, the battery was dead (duh.. should have removed it.. I know..). I tried to charge it to no avail (again... a duh thing to try ) Put in a new battery and gas and tried to start it. It started right up and ran fine... *however* .... after I put my key in and turn the ignition switch to the "ON" position, the blower moter comes on high (out the defrost vents) and a code "c" is displayed on both the Fuel Center Display (in where the number of gallons left would normally be) and the Electronic Climate Control display. I then start the car (which by-the-way starts jut fine), the fan continues to blow on high and both displays continue to read "c". After a few minutes with the engine running, both displays change from "c" to "d"..with the blower fan continuing to run on high. The following is also true:

- Service Engine Soon light is on (although this was on when I put it in storage originally)

- Attempted to extract diagnostic codes (via pressing the Off and Warmer buttons on the ECC and then trying the Fuel Used and Reset buttins on the FCD). Nothing... still c (or d) with blower on high

- Sometimes the Service AC Light comes on... but goes right off

- Unlike some others, my blower fan actually turns off when the car is turned off

- Sometimes... (rarely), when I first start the car, some words and numbers will be displayed on the FCD (like "Fuel Used in Liters".. although the car is in and originally came from the States).. but then the display goes right back to c... then d

- I can repeat the above process as many times as you like... each time gives the same result

Very frustrating...
 

·
Registered
Joined
·
18 Posts
Yes indeed! In my case I need to turn the key a few times - off-on-off-on (no engine start yet) and my displays will read... but read in Liters and Deg C. I then start the engine and after a couple of minutes... the o'l C, then D appears. I can't get my CCD to work at all. My blower fan stays on continuously as well. One other point of note here... I do sometimes get the "check A/C Light" to come on then, right after that, there seems to be a relay click and the blower fan moves from defrost position to heat position.... very strange. I have no heat... just cold air being pumped thru the system. If you find anything out please PM me directly and i will do the same.

I spoke with a Caddy dealer this afternoon... told him my story... he said that it is probably the BCM, but he cannot be sure. He said that he would like to take a look and see, but it would cost about 75.00 (the per hour going rate). If it is the BCM, he said that I am looking at a $400-600 bill. ARGH!

One final note... If I do get a BCM from a junkyard that came from an '89 DeVille, do I need to swap out the proms? My car does not have the digital dash or SRS system.

TIA
 
1 - 6 of 6 Posts
Top