Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
2004 Escalade
Joined
·
8 Posts
Discussion Starter #1
I have a 2004 Escalade and the climate control will only blow cool air from the dash vents. The air temperature will not change and it will not blow out the defroster vents. any ideas?
 

·
Registered
2004 Escalade
Joined
·
8 Posts
Discussion Starter #3
Yes the rear system does the same. If I change the temp setting the fan changes speed and the vent don't change.
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
Check the outside temp sensor
Not sure if both systems use it or not

I will check my gm service manual and see if there is something else that can cause this
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
Roger Number 1 said:
I was thinking maybe a vacuum leak?????
No vacuum worked stuff in these systems(that went the way of the dodo back in the late 80's early 90's)
Now it's all electronic controlled(even basic systems)
 

·
Registered
2004 Escalade
Joined
·
8 Posts
Discussion Starter #7
I wouldn't think it would be the temp sensor because the fan speed changes when I change the temp setting. Where is the control unit?
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
Roger Number 1 said:
I wouldn't think it would be the temp sensor because the fan speed changes when I change the temp setting. Where is the control unit?
I think the brain module is behind the control unit but I will have to check my gm service manual to be sure
 

·
Registered
2004 Escalade
Joined
·
8 Posts
Discussion Starter #9
This is what I tried this morning. I tried the HVAC Actuator Recalibration Procedure For GM Trucks and SUVs So I did this : For auto systems, press the auto button, with the key on.

Turn the ignition off.

Remove the HVAC/ECAS , 10 amp fuse in the under hood fuse box* or disconnect the battery for one minute.

Install the HVAC fuse or reconnect the battery.

Start the engine. On systems with auto a/c controls the controls will default to 74 degrees F when the ignition is turned back on

DO NOT TOUCH the a/c controls.

Let the engine run for 1-4 minutes.

Turn the ignition off for at least 10 seconds but no more than 30 seconds.

Restart the engine and then test the a/c controls


After I did this I checked and it did not set to default 74 dg. and I had the same problem of the vents only blow threw the dash vents. when I set the temp on the coldest I got cold air. When I set the temperature to 90 I got ambient air temperature. When I pushed the button for recycling the air the light would flash and then turn off.

When I checked the rear controls they seem to be working fine now. Could somebody tell me where the brain module is for the climate control?
 
1 - 10 of 10 Posts
Top