Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I'm a first-time caddy owner. Bought the Escalade with 15600 miles 6.2 AWD.i noticed that upon take-off rpm seems the rev high before shifting into the next gear. Like 2000rpm. Check engine light came on said it was a TCM also the stable link and traction. Control lights came on. After shutting the truck off the stable link and traction control lights stayed off, but check engine light came stayed on. Next day I drove it and everything was fine shifting. I refuse to take it back to the dealer that I bought it from to do their poor service in the service department. And the experience of the entire sale of the vehicle. Any suggestion on what could be going on with the truck. I do have a 2 year/24000 power train warranty. Which TCM is not covered. (Just my luck) In a complete loss of what to do since I had such horrible service with the dealership. View attachment 571298
 

·
Registered
1984 Fleetwood Brougham Coupe, 1999 ETC, 2012 ESV Premium
Joined
·
180 Posts
I'm a first-time caddy owner. Bought the Escalade with 15600 miles 6.2 AWD.i noticed that upon take-off rpm seems the rev high before shifting into the next gear. Like 2000rpm. Check engine light came on said it was a TCM also the stable link and traction. Control lights came on. After shutting the truck off the stable link and traction control lights stayed off, but check engine light came stayed on. Next day I drove it and everything was fine shifting. I refuse to take it back to the dealer that I bought it from to do their poor service in the service department. And the experience of the entire sale of the vehicle. Any suggestion on what could be going on with the truck. I do have a 2 year/24000 power train warranty. Which TCM is not covered. (Just my luck) In a complete loss of what to do since I had such horrible service with the dealership. View attachment 571298
 

·
Registered
1984 Fleetwood Brougham Coupe, 1999 ETC, 2012 ESV Premium
Joined
·
180 Posts
Unfortunately. you should bring it back to the selling dealer. Service department may be better than sales.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Unfortunately. you should bring it back to the selling dealer. Service department may be better than sales.
The service department at the dealership I bought it from is my concern I had to take it back 3 times before they were able to figure out the original problem (strut mount bolt) . Also the check engine light and the problem. Has to be happening when I bring it in. Unfourtnely the problem occurs randomly. Just did it again yesterday. I was going about 55 and felt a change in the gas pedal almost like the trans downshifted. I know I felt it in the gas pedal and herd it the engine drove it home. Today no issue. ?‍♀
 

·
Registered
1984 Fleetwood Brougham Coupe, 1999 ETC, 2012 ESV Premium
Joined
·
180 Posts
The service department at the dealership I bought it from is my concern I had to take it back 3 times before they were able to figure out the original problem (strut mount bolt) . Also the check engine light and the problem. Has to be happening when I bring it in. Unfourtnely the problem occurs randomly. Just did it again yesterday. I was going about 55 and felt a change in the gas pedal almost like the trans downshifted. I know I felt it in the gas pedal and herd it the engine drove it home. Today no issue. ?‍♀
Hopefully, someone with a similar issue responds. Most people, at one time or another have had an issue that doesn't appear when it's brought in for service.
 

·
Registered
2007 escalade
Joined
·
8 Posts
I'm a first-time caddy owner. Bought the Escalade with 15600 miles 6.2 AWD.i noticed that upon take-off rpm seems the rev high before shifting into the next gear. Like 2000rpm. Check engine light came on said it was a TCM also the stable link and traction. Control lights came on. After shutting the truck off the stable link and traction control lights stayed off, but check engine light came stayed on. Next day I drove it and everything was fine shifting. I refuse to take it back to the dealer that I bought it from to do their poor service in the service department. And the experience of the entire sale of the vehicle. Any suggestion on what could be going on with the truck. I do have a 2 year/24000 power train warranty. Which TCM is not covered. (Just my luck) In a complete loss of what to do since I had such horrible service with the dealership. View attachment 571298
Escalades, tahoes, etc. seem to have had a camshaft problem and of course the camshaft bearings. GM has discontinued 2 of the original camshafts. Dealership chased after this problem for over a decade. Transmission, fuel pump, oil pump, etc. Finally saw a post showing when they pulled the engine camshaft they saw the bearings all broken and blocking oil flow etc. my dealer wanted to replace engine. go figure.
 

·
Registered
2008 Cadillac Escalade
Joined
·
21 Posts
For the stabilitrak and traction control you may want to check the brake fluid reservoir to see if it is topped off. Checkout my video.
Resolving a Service Brake System Light Brake, Service Stablitrak, Traction Control Off
 
1 - 7 of 7 Posts
Top