Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
2005 CTS
Joined
·
22 Posts
Discussion Starter #1
Hey everyone-

Just to preface, I have searched the forum and there are quite a few topics on this, but didnt find anything to quell my nerves.

Last Saturday, my check engine light came on while driving down the interstate. Not knowing what was going on, I found the nearest pep-boys just to make sure my car wasnt about to fall apart.

They checked the codes and it was giving a duplicated : P0036

I know that the code involves the sensors in the exhaust so Im looking to you guys to tell me what you think it is.


Just some background on the car: 2005 CTS 3.6 w/ 98500 miles. I also got a muffler/res delete back in december.

Thanks guys!
 

·
Super Moderator
'05 CTS-V
Joined
·
8,296 Posts
They checked the codes and it was giving a duplicated : P0036

I know that the code involves the sensors in the exhaust so Im looking to you guys to tell me what you think it is.
I think it's one of the sensors in the exhaust (a.k.a. the oxygen sensor).
 

·
Registered
CTS
Joined
·
256 Posts
Oxygen Bank 1 Sensor 2, passenger side after cat if I remember correctly. You can probably do this yourself, not too hard. I recommend snipping off the O2 sensor wire and using a deep socket to crank them off as opposed to using the O2 socket kit. Running the car for a bit and letting the exhaust pipes heat up can really help to loosen them up too. Careful not to burn yourself though.
 

·
Registered
2007 6 speed manual tarnished platinum
Joined
·
377 Posts
That's the heater control circuit and I've had this on and off for a while, replaced the sensor and came back, after digging around that's usually a wiring problem, I've ordered a delco pigtail to splice on since those wires look toasty from the catalytic converter. Yet to put it on though. It comes on for a day then goes back out then comes back. Since they had your exhaust off the probably pulled on that when they disconnected it.
 
1 - 4 of 4 Posts
Top