Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
08’ STS-V
Joined
·
15 Posts
Discussion Starter #1
Last night i was driving my V pretty hard when these 2 codes popped up. I reset the computer and it seems to go away. If anyone has any info lmk thanks🙏
 

Attachments

·
Registered
2007 STS-V
Joined
·
23 Posts
I get the p12b code every once and a while when I let the engine get close to redline. In the past I was getting it all the time. I changed the pressure sensor which is cheap and easy. Tightened all the screws holding down intake and super charger. Tightened all the hose clamps on intake pipes. After that I rarely see it. I think I have a small vacuum leak somewhere. I will eventually change the intake gaskets to try and correct for good. Definitely just go around the engine and check your vacuum lines and all that stuff I mentioned first.
 

·
Registered
08’ STS-V
Joined
·
15 Posts
Discussion Starter #3
I get the p12b code every once and a while when I let the engine get close to redline. In the past I was getting it all the time. I changed the pressure sensor which is cheap and easy. Tightened all the screws holding down intake and super charger. Tightened all the hose clamps on intake pipes. After that I rarely see it. I think I have a small vacuum leak somewhere. I will eventually change the intake gaskets to try and correct for good. Definitely just go around the engine and check your vacuum lines and all that stuff I mentioned first.
Yeah thats what i figured! Thanks for helping
 

·
Registered
2002 Escalade & 2008 STS-V
Joined
·
15 Posts
Is your intercooler pump working? I've been dealing with the p012b code and I found out that my pump is toast so I'd be willing to bet that's it!
 

·
Registered
08’ STS-V
Joined
·
15 Posts
Discussion Starter #5
Is your intercooler pump working? I've been dealing with the p012b code and I found out that my pump is toast so I'd be willing to bet that's it!
I believe that might be it, gonna buy a jabsco pump and an upgraded heat exchanger from timmy
 

·
Registered
2002 Escalade & 2008 STS-V
Joined
·
15 Posts
I believe that might be it, gonna buy a jabsco pump and an upgraded heat exchanger from timmy
yeah that code comes on when it can detect a fault in the intercooler pump... Idk why it doesn't have a more specific code but good luck!
 

·
Registered
2007 STS-V
Joined
·
23 Posts
Thanks for this extra info. Even though I have replaced the stock pump once, I believe my intercooler pump is also not working anymore. Might explain why I still see it every once and a while.
 

·
Registered
08’ STS-V
Joined
·
15 Posts
Discussion Starter #8
Thanks for this extra info. Even though I have replaced the stock pump once, I believe my intercooler pump is also not working anymore. Might explain why I still see it every once and a while.
Jabsco pump is a HUGE upgrade from stock. Recommended, still waiting for the heat exchanger.
 
1 - 8 of 8 Posts
Top