Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 13 of 13 Posts

·
Registered
2006 2.8 CTS
Joined
·
21 Posts
Discussion Starter · #1 ·
hey guys,

i had another post going on here about the problems ive had with my 2006 2.8. Back a few months ago I had the common occurence of my rad hose blowing out. had to get brand new rad and hoses. just before christmas time, i was driving for about an hour and a half on the highway. when i went to accelerate while cruising at about 110, my car jolted, almost as if i had hit a pothole. this wasnt the case. when i was pulling off the highway, my car was whirring and when id drop down into 2nd and 1st gear, my car acted as if my brakes were being applied. immediatly i knew it was the transmission. got it towed back home, and in the shop they said my transmission had grenaded. ended up getting a used tranny with about 75000k on it. 1900 plus install.

so about 2 weeks ago, while driving on the highway again, same "pothole" effect, and i immediatly knew i just blew the transmission again. i treat this car great, it had the used transmission in it for about 2000k. can anybody think of what is causing my transmission to continually fail? in the past few months, ive dropped $4000+ into repairs, only for it to fail time after time. im just about sick of my car and ive only had it for a year.
 

·
Registered
2003 CTS "Ebony Maria" 2005 Cadillac STS "Grace"
Joined
·
6,414 Posts
have you had the torque converter checked while they were fixing this? that is the only thing i can think of off hand that could possibly have anything to do with this. and you say cruising at 110, that is not necessarily cruising, that is stressing your ride almost to the max...
 

·
Registered
06 Cadillac CTS 3.6L [Sold :( ] 02 Mustang GT 5Spd
Joined
·
1,161 Posts
...and you say cruising at 110, that is not necessarily cruising, that is stressing your ride almost to the max...
He's from ontario. odds are he's talking kilometers an hour not miles per hour. 110 is only about 65 or 70 miles an hour.
 

·
Registered
2006 2.8 CTS
Joined
·
21 Posts
Discussion Starter · #4 ·
yeah, sorry, just used to talking in kms. haha. im getting another used transmission (free of charge thankfully) and am currently fighting with GM Canada to admit the work wasnt done right.
 

·
Registered
2006 CTS-V
Joined
·
4,969 Posts
Get an external cooler, dodge the rad altogether, and make sure the fluid is clean. Did anyone mention finding coolant in the trans oil last time?
 

·
Registered
2006 2.8 CTS
Joined
·
21 Posts
Discussion Starter · #7 ·
everything was clean. the thing that pisses me off the most about this is there was no warning signs. nothing on the DIC, not even a check engine light. even after the incident.
 

·
Registered
2006 CTS-V
Joined
·
4,969 Posts
everything was clean. the thing that pisses me off the most about this is there was no warning signs. nothing on the DIC, not even a check engine light. even after the incident.
I noticed this when I blew a trans line off the ext. cooler. There were no DIC warnings that state the trans oil is low.

That didn't flag, but the stupid P0128C code pops up every time I turn the damn heater on when its cold.

[update for trans line]
everything was good, just needed a larger ext. cooler then the one i was using.
 

·
Registered
03 CTS 3.2L (Sold) / 09 CBR 600rr /2014 GMC Sierra
Joined
·
7,872 Posts
have you had the torque converter checked while they were fixing this? that is the only thing i can think of off hand that could possibly have anything to do with this. and you say cruising at 110, that is not necessarily cruising, that is stressing your ride almost to the max...
110km is actually slow around here...if you are doing under 20 over on the main highways people flash their lights at you and give you the finger... 130 is cruzing, except long weekends..then 115.
so basically it depends on where and when. today i was doin 130 on the 400s and i was getting passed and gettin dirty looks like i was doin 20 under....

i would say call the place you got that tranny from because its probably defective, no way should it blow like that.
isnt the torque converter inside the tranny? i thought it was but really have no clue...im no mechanic.
 

·
Registered
2006 2.8 CTS
Joined
·
21 Posts
Discussion Starter · #10 ·
i honestly have no idea. im getting another transmission free of charge. but what are the odds thats i blow two transmissions, in the exact same with, in about a month and a half? im afraid that once this is transmission is put in, i'll end up being stuck on the side of the highway again.
 

·
Registered
Joined
·
37,297 Posts
When I sold my CTS at 65000 miles, it was on its third torque converter. I suspected something in the tranny causing the TC to keep failing. Maybe like TX suggested, you are having the exact opposite of the problem I was having.

I know it sucks having a car that bleeds you like this. I was lucky to be under warranty, but I also suspected I was just going to keep chewing up TCs. I never had any other problems with the car. I actually sometimes wish I would have just kept it.
 

·
Registered
2006 2.8 CTS
Joined
·
21 Posts
Discussion Starter · #12 ·
so, i just got my car back. it appears when i got my rad done, one of the stupid mechanics decided to leave a hose clamp on my line that runs from the rad to my trans. so very minimal fluid was getting thru, thus burning out my trans again and again. my question is, why the hell wouldnt my stupid car tell me! hopefully everything works out from here on out. *knock on wood*
 
1 - 13 of 13 Posts
Top