Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a beautiful 89 Fleetwood that was driving strong, it only has 89k miles on it. All of a sudden, she starts up fine...I have trouble getting her moving...when I do...she doesnt like it when I hit the brakes or stop at red lights. She fusses when I hit the gas. I took her to a shop, they did a diagnostic test, she came up clear. They tested the computer and nothing happened. They said it was either the carb or ignition system, they couldnt guarantee either or and if I wanted to have it checked out, it would cost me a lot. Does anyone know if the Fleetwood is prone to any problem like this? I do not want to get rid of her, but I might have to..please help. [email protected]
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
Welcome!! Thanks for siging up!!! :wave:

I dont really know, but I can guess it could be a missing cylinder..... Either spark plug or distributor....... I couldnt tell you for sure, someone will chime in for more info......
 

·
Registered
Joined
·
6,471 Posts
Unfortunately, the discription is rather vague and there could be many things giving you the problem.
It could be as simple as a vacuum leak caused by a cracked vacuum line, or as complicated as a dropped cylinder from lack of compression. One way to find out if it's a lean condition is to take a shop rag and very slowly cover up the top of the carb (primaries). If the engine smooths out as you start to cut off air through the carb, it's a lean condition like a vacuum leak etc. If it just gets worse and stalls as you do it, then I'd look for an ignition issue. It could also be a very RICH condition. in this case, give it a vacuum leak and see if it runs better. This would indicate something like a stuck float or similar problem.
 
1 - 3 of 3 Posts
Top