Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Cadillac
Joined
·
8 Posts
Discussion Starter #1
Ok guys. I'm totally lost on this!

Love my car its a 1997 El Dorado although it's been giving me a hard time lately.

Here's the situation:

I have 3 consistent codes.
P1350 - Ignition Control System
P1375 - IC 24X Reference Circuit High Voltage
B1910 - Generator L-Terminal Open Circuit

When driving after the car warms up it will either stall or continue running.
Under both conditions the tach drops to zero and the car begins to miss very bad.

If trying to restart after a stall it takes a lot longer to fire. I'm assuming its kicking back to some sort of base timing.

Anyone have any similar issues and what was the cure?

Appreciate the help in advance! Thanks!
 

·
Registered
Cadillac
Joined
·
8 Posts
Discussion Starter #2
FYI replaced both crank sensors and seems to have solved the problem. Was a rather easy job to do. Used two extensions on the ratchet with a swivel at the end. Wasn't as bad as it looked to do.
 

·
Registered
2005 SRX; 2004 Deville DTS; 1999 Seville STS; 2010 DTS;
Joined
·
156 Posts
i had same codes, replaced both sensors (no fix), replaced wires from sensor to the icm (no fix), replaced wire end connectors (no fix). The first time I had these codes last year, all i did was replace harness wires and it solved the problem for about 6 months til it happened again and I performed what I stated above the 2nd time around. After a few weeks of putting it off and not driving the car, i went and bought a new ICM this morning. I"ll let you know if it fixes the exact same problems you were having prior to your ckp replacements.
 
1 - 4 of 4 Posts
Top