Cadillac Owners Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hello everyone. I have a 2006 Cadillac CTS and very rarely I have an issue with this. Maybe once every month my car will be in a slow idle (say in a parking lot) and all of the sudden it starts dragging and grinding to a complete stop. When I go to accelerate again it will do it again. I have to just let the car sit for about five minutes before driving again. Any ideas on what it could be?
 

·
Super Moderator
'05 CTS-V
Joined
·
8,187 Posts
So the engine is still running when this happens? Or does it stall? And you're not touching the brakes?

Sounds like it would have to be a transmission issue.
 

·
Registered
2007 CTS 3.6 >131k miles
Joined
·
695 Posts
I agree with @AAIIIC this sounds like a transmission problem. Has the ATF ever been changed? If not that's where I would start.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Hey guys. So every now and then when I am in a parking lot or something going very slow my car will grind to a stop. I won’t be pressing either pedal and it stops itself. It sounds like metal dragging and It almost feels like a pulsing affect until it is completely stopped. It doesn’t happen very often but is definitely frustrating when it does occur. Any ideas on what might cause this?
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
69,374 Posts
Good afternoon. I merged your two identical threads into this one. No need to post multiple threads on the same problem. Thanks.
 

·
Registered
2007 CTS 3.6 >131k miles
Joined
·
695 Posts
@Nolanryan00 did you ever determined whether the ATF has been changed, as I asked in you other thread (now above this post)? If no records, did you check and/or replace the ATF?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
My bad. There was a few problems with my car that I forgot I already asked about it. But yes I got the ATF changed about 3 months ago. But I’m going to get it serviced again
 

·
Registered
2007 CTS 3.6 >131k miles
Joined
·
695 Posts
If it was already changed with compatible ATF and correct procedure, I doubt that is the problem. That is unfortunate because ATF is a relatively easy fix. Instead you will need to explore other possibilities such as the SWPS as @Argent suggested.
 

·
Registered
2007 CTS 3.6 >131k miles
Joined
·
695 Posts
If you like DIY projects you could follow this thread from the CTS-V forum. The sensors sounds like a lot of work but steering columns really aren't that hard to do. Just make sure you disconnect the battery first so the air bags don't discharge!
 
1 - 14 of 14 Posts
Top