Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
04 CTS SPORT/LUX W/NAVI LIGHT PLATINUM ON BLACK- COOL MODS!
Joined
·
1,313 Posts
Discussion Starter · #1 ·
When i start my car, occasionally, the yellow light by the "P" does not light up. When this happens, my gas gauge doesn't move and the car goes into anti-theft mode if i drive it (all lights on the dash shut off).

I usually correct this by normally restarting the car a couple of times and if that doesn't work i push the shifter all the way up into the P and hold it there while i start the car.

Has anyone had a similar problem?
 

·
Registered
04 Blacked Out CTS 3.6L
Joined
·
19 Posts
i had a similar problem were the anti-theft and tc light came one, temp and gasoline temp didnt work and the shifter light would turn on and it ended up being the ecm so it might be going bad. if your keys get stuck in the ignition then thats the sign that your ecm is bad.
 

·
Registered
03 CTS 3.2L (Sold) / 09 CBR 600rr /2014 GMC Sierra
Joined
·
7,872 Posts
Sounds like the car can't tell where the shifter is located. Maybe something has shifted,, streched or become loose.
I think its a mechanical issue not electrical.
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,858 Posts
Does your dashboard have the clock or the temp gauge?

If it does have the clock, then it's most likely the dash board itself. So this would be a great time to upgrade. :) There is a known problem with the dashboard with the clock, where the solder joints weren't all so great.

KOT
 

·
Registered
04 CTS SPORT/LUX W/NAVI LIGHT PLATINUM ON BLACK- COOL MODS!
Joined
·
1,313 Posts
Discussion Starter · #5 ·
I have the temp gauge on my dashboard but the isn't my concern as that problem only arises when i drive the car with no yellow light by the shifter. I'm thinking it's some sort of connection.
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,858 Posts
The reason why I mentioned the dashboard, is because it also effected the shifter as well. I saw a diagram on here that showed the two modules interlinked to each other. Even though you have the temp gauge, it still maybe a possibility that yours is messed up.

KOT
 

·
Registered
04 CTS SPORT/LUX W/NAVI LIGHT PLATINUM ON BLACK- COOL MODS!
Joined
·
1,313 Posts
Discussion Starter · #7 ·
Looks like GhettoMike was right.

I took my car into the dealer this morning to take care of the brake line recall i had neglected over the past year. I mentioned my little problem and he said he would look into it. Just got a call back and the dealer told me that the problem was occuring because the shifter cable was misaligned and thus the car couldn't tell what gear it was in. When the car can't tell what gear it's in, while it's driving the anti-theft goes off and all other crazy things start happening.

Hopefully, i don't have this problem again but i'm a bit concerned because while the misaligned shifter explanation will suffice for the whole car not knowing if it's in park thing, i dont think it explains why sometimes all the power goes off in the car when i try to crank (my battery is good). When the power goes off in the car, i usually have to pop the hood and move around the terminal connections--this brings the lights back.

What do you guys think?

Also, forgot to mention-- The dealer covered this diagnostic and fix at no cost so a big thank you to North Bay Cadillac. They never dissapoint me :)
 
1 - 7 of 7 Posts
Top