Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
One day the brakes went out on my '85 deville, took it to a place, and one of my lines was cracked and leaking, slowly but not gushing. Had a partial line replacement and that solved the problem for a while. Now my pedal is very soft and travels a long ways before i get any stopping power, but as soon as I get stopping power the pedal gets very hard to the point where I cant get the brakes to even lock up. My brake light comes on and goes off sparatically, took it to midas and the guy told me that the light was because i had a bad vacume sensor but everything else was fine, So HE being the brake expert that HE is NOT, disconnected the sensor and said my problem was solved, HA not solved at all. I reconected the sensor and found some bad vacume lines and replaced them and it helped a little bit but the brakes still are not dependable if I need to stomp on them they simply are not there for me. My fluid level is fine, So does anyone out there know what could be the problem(s).:confused: Sorry for the long post but there was alot of history for these brakes.
 

·
Registered
2003 STS w/BoseNav, 1993 Deville, 1985 Deville
Joined
·
1,089 Posts
Were the brakes bled? Might be air in the lines.

This car has an auxilliary vacuum pump. I wonder if that is worn out or inoperative. I've had to replace the one in my 85.
 

·
Registered
1999 STS - diamond white
Joined
·
5,229 Posts
Yup, sounds like the system wasn't bled properly or at all after replacing the line. Any time a brake system is opened the air must be bled out.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
I was wondering the same thing about the lines being bled properly, I will give it a try this weekend and see what happens. If that was the problem I will be upset since I was charged for a brake bleed by the shop that replaced the line. One last question would air in the lines be cause for the brake light to come on in my dash?
 

·
Cadillac Technician
none
Joined
·
11,051 Posts
You may have a small leak somewhere that is letting fluid out and air back in.
There are not many things that can cause low brake pedal, air is one of the big ones.
The proportioning valve senses pressure differential between the two hydraulic circuits. If there is air in one channel the pressure will be lower and the prop valve will turn the light on.
 

·
Registered
2003 STS w/BoseNav, 1993 Deville, 1985 Deville
Joined
·
1,089 Posts
jbrunell said:
One last question would air in the lines be cause for the brake light to come on in my dash?
You might need a new master cylinder.
 

·
Registered
Joined
·
201 Posts
My 87 Brougham does the same thing. I'm not losing any fluid. I think a good bleeding will help.
I think I'll do it this weekend. I rebuilt the carb. last weekend.

Later.........and good luck!
 
1 - 7 of 7 Posts
Top