Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I've been having trouble with my car
Stalling. I've heard different things about the cause but I think my best bet is the ISC. But basically it randomly and take several attempts to start again. Only way I can keep it running is by constantly having the accelerator push down without letting off even at red lights.

The codes I I've pulled are:

E52-PCM- memory reset
E52-Pass- key control problem
E60- cruise- transaxle not in drive
E63- cruise- vehicle speed too high
F32-BCM- ECM data problem

So I'm thinking the big problem is probably the F32 code?
Thanks for any and all help with this.
 

·
Registered
1985 Sedan DeVille
Joined
·
1,883 Posts
F32 is pretty good indication that one or the other is bad

When you turn the key just enough to do a lamp test, the Service Soon and Service Now lights should both come on. If they don't, then that is strong indication of ECM failure

BCM failure is usually seen by stuff like fuel gauge not working

You will need to pull the box from your car and get the number, then search for that. Usually some on ebay.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
F32 is pretty good indication that one or the other is bad

When you turn the key just enough to do a lamp test, the Service Soon and Service Now lights should both come on. If they don't, then that is strong indication of ECM failure

BCM failure is usually seen by stuff like fuel gauge not working

You will need to pull the box from your car and get the number, then search for that. Usually some on ebay.
Well, I just did the lamp test. Only my service soon like from the two comes on, and it's only for one second. My gas gauge works, shows my gallons, but lately it's been reading with like 5 or 6 gallons, but shows my distance and L. But it only used to read that when at 4 gallons.
 

·
Registered
1985 Sedan DeVille
Joined
·
1,883 Posts
Between the F32 code and the Service light failure, it sounds like your ECM is shot. Probably ought to pull it out and give it a sniff test--if it smells like burnt electronics then its definitely bad.

I don't know where its located on your 88. On my 85, one of the computers is behind the glovebox, the other is behind the carpet on the passenger side fender wall. Might need to get some help.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #9
Between the F32 code and the Service light failure, it sounds like your ECM is shot. Probably ought to pull it out and give it a sniff test--if it smells like burnt electronics then its definitely bad.

I don't know where its located on your 88. On my 85, one of the computers is behind the glovebox, the other is behind the carpet on the passenger side fender wall. Might need to get some help.
Thank you so much! You've been more then helpful! Btw it is located by my passenger side.. I'll let everyone know about if it works after I replaced the ecm
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
Well if changed tg Emc problem still persist and only error code I get now is the f 32 code. I've also change the idle speed control from a 89 Deville in a junkyard. Any ideas?
 

·
Registered
1985 Sedan DeVille
Joined
·
1,883 Posts
Best guess at this point would be a chaffed or loose wire. Probably time for some diagnostics.
 
1 - 12 of 12 Posts
Top