Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
UGH! My Bose radio in my 2000 eldorado suddenly keeps saying CD Error. Even if I don't put a CD in, every 5 seconds it makes the ejecting sound and says CD Error on the screen.

Anyone know whats up??? :mad: :confused: :confused:
 

·
Registered
Joined
·
166 Posts
BlackEldo45 said:
The Dealership ended up replacing the radio. Good thing for the warrantee, it was 750 bones.
DAMN! :vomit:

I just got my '99 STS, and it started to do the SAME thing. I put a CD into the head unit, it says CD Initializing, then spits it back out. Did they say what it was?

I have 43,000+ miles on mine. I'm going to call the local dealer here tommorrow and find out if I'm still under warranty. My car was actually manufactured in 1999, not 98, so there's a slight chance I'm under warranty.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
UGH! That suks. They said that some mechanism broke inside the radio. The part that sucks though is that the radio replacement was like 750 buks! I was under warantee though. Then the radio that I got for a replacement broke, the screen went crazy. They ended up getting back my original radio after it was fixed and put it back in. So the problem can be fixed. I would see if that would cost less that getting a replacement first.
 

·
Registered
2005 CTS-V, 1994 Infiniti Q45
Joined
·
7,658 Posts
You may be able to send it back to bose and have them rebuild it...... I know they do this with the 1st gen Qs, they have a thing with bad speakers with amps built in..... Maybe they could do the same for you, and then you would have some warranty on it......
 

·
Registered
Joined
·
166 Posts
BlackEldo45 said:
UGH! That suks. They said that some mechanism broke inside the radio.
THAT'S EXACTLY IT !!!!!

This is the strangest thing I've seen. The CD will sometimes play. I can stick a CD in there, and it will go, but then anywhere between tracks 3-5 it will start getting noisier and noisier until it stops, gives an error and spits the CD out. Then, if I put another CD in, it makes a noise like something is stuck, and then spits the CD out.

Argh.

I saw that carstereohelp.com site. I'm hoping that maybe it's just the CDM that's messed up? Maybe I just can get a replacement CDM? Or perhaps some nice person out there who ripped theirs out will sell it to me cheap... hahaha.. :(

I'll be calling the local dealer tommorrow to find out if I'm still under warranty. Starting to think it's null- got all the titlework done today, and it was first titled back in 06/99.
 

·
Registered
2000 Deville, 1999 STS
Joined
·
115 Posts
Reviving an old post. I just bought a 1999 sts and I'm getting the exact same problem. When I insert a CD it'll say "CD Initializing" and then eject the disc saying "CD Error". But once in a while it'll actually work. Also, sometimes I'll hear some static on certain tracks at random. I was thinking about trying a cd lens cleaner but I wasn't sure if that's a good idea. I've read mixed reviews. Some say its absolutely fine while other swear against it saying it can get jammed because of the brushes. Any ideas? Thanks.
 

·
Registered
2000 Deville, 1999 STS
Joined
·
115 Posts
Yup, just tried that yesterday. It isn't perfect, but its certainly much better. It's accepting most of the CDs I insert. Thanks!
 
1 - 10 of 10 Posts
Top