Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
2008 STS4 V8 1SG Platinum Edition
Joined
·
606 Posts
Discussion Starter #1
Hi everyone. After pairing my sprint sanyo phone to the 05 bluetooth system, the calls seem to work great. On my side anyway. The call recipients all complain of noise and they are telling me their voices echo on their side. I tried turning the volume down and talking in different directions. Any thoughts if this is correctable or is it just a flaky system. I have a trusty headset so I am not too worried. Would love to use it if I can adjust anything on the bluetooth side....

Steve
 

·
Registered
Cadillac '05 STS V6
Joined
·
42 Posts
Don't use the headset....use the car's audio system. The echo likely results from speaking into the headset and the car's audio at the same time.
 

·
Registered
2005 STS V-8 1SF
Joined
·
32 Posts
I have a list of phones (3) that GM will only recommend to use with our 05's Bluetooth system. I will try to remember to post it when I get home. I have the same problem and took it to the dealer. The tech had a motorola razor that worked fine, which is funny because it is not on GM's list. Anyway, they blamed it on my phone and not the bluetooth system.
 

·
Registered
Cadillac
Joined
·
23 Posts
I have a Blackberry Curve from Bell Canada, and there is a feature in the bluetooth options for echo reduction, and it seems to work good, the only thing I get once in while when I answer the phone is a loud tone in the speakers before the connection is made. Or somethings I click the screen to answer the phone and the stereo comes back on for a second then the connection is established.
 

·
Registered
2006 STS 1SG & 2007 STS 1SE
Joined
·
13 Posts
The STS microphone & its placement in the mirror do pick up a lot of noise and may not be best for the driver's voice. Some people have reported a lot of improvement by installing a different microphone above the drivers head or on the 'B-pillar'.

Your callers' complaints are common. Did lowering the volume help at all?

I have a Verizon/LG phone and don't have any problems. Some people have had phones that stay active even while in Bluetooth and have echo problems for that reason. Do you have a nearby Sprint phone store that might work with you on the phone? Force-1 is right that there may be an update for your phone.

Good Luck.
 

·
Registered
Catera
Joined
·
21 Posts
I have an 08 STS and get an occasional complaint about echo's on the other end...however, when I turn the volume down on my end it seems to fix the problem.
 

·
Registered
2008 STS4 V8 1SG Platinum Edition
Joined
·
606 Posts
Discussion Starter #9
wow thanks for all the suggestions!! I have tried updating the phone's firmware. The sprint site shows we are up to 1008SP and I have 1002SP. I tried over and over to update it and the phone returns the message "no update is available" so I don't know what is going on. I also have a Blackberry Pearl that I will try to pair a little later today to compare. I thought I tried turning the volume down but that didn't help if I remember correctly. I will try it again today. To answer PGW85706's question, I was not using my headset and the blue tooth in the car at the same time. that is not possibly. I was only saying that I have a BT headset that works fine but would rather use the car when I am in it.

I am getting the Onstar upgrade tomorrow night and am hopeful that the BT and the Onstar share components and the upgrade might fix my issue...

I am also planning on upgrading to the Treo Pro and hopefully that might help a bit...
 

·
Registered
06 Cadillac STS
Joined
·
352 Posts
wow thanks for all the suggestions!! I have tried updating the phone's firmware. The sprint site shows we are up to 1008SP and I have 1002SP. I tried over and over to update it and the phone returns the message "no update is available" so I don't know what is going on. I also have a Blackberry Pearl that I will try to pair a little later today to compare. I thought I tried turning the volume down but that didn't help if I remember correctly. I will try it again today. To answer PGW85706's question, I was not using my headset and the blue tooth in the car at the same time. that is not possibly. I was only saying that I have a BT headset that works fine but would rather use the car when I am in it.

I am getting the Onstar upgrade tomorrow night and am hopeful that the BT and the Onstar share components and the upgrade might fix my issue...

I am also planning on upgrading to the Treo Pro and hopefully that might help a bit...
Try taking your phone to a Sprint Center and ask them to update it. That's what I did, and it solved several of my Bluetooth problems.
 

·
Registered
2008 STS4 V8 1SG Platinum Edition
Joined
·
606 Posts
Discussion Starter #11
good succestion, I may try that over the weekend. To update the Onstar upgrade... The upgrade went well. It included a new antenna, digital module and a new rear view mirror! anyway, Onstar voice recognition works great. Unfortunately the Onstar digital upgrade did nothing to fix the voice recognition on the car itself which is horrible to put it mildly. Where else can you ask to advance to the next CD track and you get "System temperature 85" or you ask "What can I say" and she says back "System fan high"... gotta love it...
 

·
Registered
2006 STS 1SG & 2007 STS 1SE
Joined
·
13 Posts
Onstar isn't directly related to VR. Have you had TSB 05-08-126-001B (Bluetooth, etc.) applied to the NAV? It reduces the number of commands (a bit) and improves VR. It takes some practice, too.

Search the forum for details.

Good Luck!
 
1 - 12 of 12 Posts
Top