Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1 (Edited)
Hi all!

I have a 2004 Cadillac Escalade Platinum. Lucky me, I went to turn on the air and it won't blow in the front at any speed. Only the rear. The blower relay seems fine so I suspect it's the Blower Motor or Resistor. More likely the motor since it won't go at any speed.

Need help with some part numbers. Called my local parts department and they said they wouldn't give me the part numbers on top of being 3 times more expensive than online.

The problem I'm have is there are 3 or4 different part numbers for GM. I pulled out what was in my car and it's as follows:
Blower Motor - Bosch 52400177. It's the kind you rotate out. According to gmpartsdirect.com I would use this
But it has 3 bolts, my current one has none.
It looks like this

As for the resistor. Gm parts direct again says this but my plug doesn't match that. It only has 3 prongs instead of 6
It looks like this

SOLVED

Okay, I figured it out. ACDELCO 1580875 is for the rear blower but is mislabeled in multiple sites as a front blower.

The correct part is 1581646 also 1581647 seems identical but I could be wrong.

And flyingdutchman was correct 19260762 is the updated part which is ac delco 15-81733 and does require swapping the harness for the new connector.

THanks.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Okay, I figured it out. ACDELCO 1580875 is for the rear blower but is mislabeled in multiple sites as a front blower.

The correct part is 1581646 also 1581647 seems identical but I could be wrong.

And flyingdutchman was correct 19260762 is the updated part which is ac delco 15-81733 and does require swapping the harness for the new connector.

Thanks.
 

·
Registered
Joined
·
108 Posts
Hi all!

I have a 2004 Cadillac Escalade Platinum. Lucky me, I went to turn on the air and it won't blow in the front at any speed. Only the rear. The blower relay seems fine so I suspect it's the Blower Motor or Resistor. More likely the motor since it won't go at any speed.

Need help with some part numbers. Called my local parts department and they said they wouldn't give me the part numbers on top of being 3 times more expensive than online.

The problem I'm have is there are 3 or4 different part numbers for GM. I pulled out what was in my car and it's as follows:
Blower Motor - Bosch 52400177. It's the kind you rotate out. According to gmpartsdirect.com I would use this
But it has 3 bolts, my current one has none.
It looks like this

As for the resistor. Gm parts direct again says this but my plug doesn't match that. It only has 3 prongs instead of 6
It looks like this

SOLVED

Okay, I figured it out. ACDELCO 1580875 is for the rear blower but is mislabeled in multiple sites as a front blower.

The correct part is 1581646 also 1581647 seems identical but I could be wrong.

And flyingdutchman was correct 19260762 is the updated part which is ac delco 15-81733 and does require swapping the harness for the new connector.

THanks.
If the blower turns on but can't change the fan speed it's the resistor. If it doesn't turn on at all it's either bad relay or bad blower motor.
 
1 - 6 of 6 Posts
Top