Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
newbie here,:) so bear with me. Just posted this in the seville forum and realized it should be here instead.
"Bear with me this is my first post. I am the new owner (5 hrs ago) of a 1994 sedan Deville. The blower motor is not blowing at all. I looked in the owners manual and really could not find a fuse or relay that was for just the blower motor. Also, I've noticed that the horn doesn't work. For the horn relay, (30 amp Circuit Breaker) the owners manual also states that this CB is for the turn signals , and they work fine"
Any help out there for a newbie.
Bob
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
87,173 Posts
:welcome:First check the connector at the blower. Others have reported them being burnt and causing a failure. That said, these blower do have a tendency to fail (been there, done that).

A FSM (factory service manual) will be a worthwhile investment if you are going to do your owm work.

I'll delete the post in the Seville section for you.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
thanks will take a look in the morning. Also, in regards to the horn, while it doesn't work from the steering column, it certainly works when you accidently activate the security system. Are they on different circuits, or even different horns.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
87,173 Posts
Can't help much with the horn problem. Maybe someone else can.
 
1 - 4 of 4 Posts
Top