Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Greetings all...

I've just purchased a 1990 DeVille with 215k. Runs great, with some minor problems. I noticed that someone has used a toggle switch to cut power, from the module, so it won't constantly run. Reading info in this forum, I have found that it is a bad Blower Motor Control Module.
Now with this info at hand & locating it, I have 2 other Caddys for parts. One being my recent, 1987 Cadillac BroughamRWD & a 1985 DeVille. Looking around in the 87, I couldn't locate the Module. Does it have one or is it tucked away somewhere I'm not looking? If it has one, can I swap it out? The same as the 85 goes, which isn't at this location, so I can't physically look to see if it has one & if so, can I swap that one also?
I just changed the heater core, thanks to the great advice I read here also. Thats cured, so thats one less problem. :yup:
Any suggestions would be greatly appreciated....
 

·
Registered
1968 Cadillac Sedan deVille, 1994 Chevrolet G20
Joined
·
2,795 Posts
Follow the wire from the blower, that goes directly to the module. I believe that it is on top of the HVAC air box by the firewall.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Thanks, Dave for the input... I used the module from my 85 Deville, it was the same , except for the connectors on top had different plugs. The 90 had the moisture proof plugs where as the 85 had regular plugs. The wiring colors were the same, so I just switched over connectors at the wires and it works great..
 
1 - 3 of 3 Posts
Top