Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I just replaced my alternater belt on my 87 Brougham and now every time the heat comes on it squeals like a pig. Even after trying to adjust the tension it's still doing it. What the heck is wrong with this thing? It's loud enough that I'm sure it's annoying the neighbors first thing in the a.m. and it's giving me an awful headache. HELP!!!!!!!!!!!!
 

·
Registered
Joined
·
1,805 Posts
dexter28 said:
I just replaced my alternater belt on my 87 Brougham and now every time the heat comes on it squeals like a pig. Even after trying to adjust the tension it's still doing it. What the heck is wrong with this thing? It's loud enough that I'm sure it's annoying the neighbors first thing in the a.m. and it's giving me an awful headache. HELP!!!!!!!!!!!!
i think you can use some sort of lubricant on it.
I am had the same problem with my eldo sprayed wd40 and now its gone but now i get a whisling noise when the heat is on and i can hear from in the car.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
I thought about using the WD-40 but I'm worried about causing belt corrosion. Being as WD-40 is petroleum based it causes the materials in the belt to break down. I'm going to try adjusting the belt AGAIN with the engine and the heater running. I did this once before and thought I solved the problem but the next day it was doing it again.
 

·
Registered
Joined
·
18 Posts
Try "belt dressing." Should be able to fine it at any parts store.
 
1 - 4 of 4 Posts
Top