Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
99 STS 47k miles
just bought it couple weeks back.
i'm getting what sounds like a belt slipping - ONLY when A/C compressor is on. there is a chirp and i can feel a tiny jerk - as though you turned the a/c comprssor off and on rapidly. seems to happen at regular intervals (approx 22 seconds)....new belt needed?
 

·
Registered
Joined
·
6,471 Posts
The A/C compressor might be bad, the A/C charge might be too high, the belt might be bad, or the belt tensioner might be bad. Start with the easy stuff, make sure the A/C compressor is functional.
 

·
Registered
2001 BMW M5 - Alpine White
Joined
·
226 Posts
Mine has been doing the EXACT same thing. It has been doing it for about a year now. It started at around 50k miles. It only does it when the AC is on. I have very cold air, which leads me to believe that the compressor is good. I haven't looked at anything else. It seems that if the belt is slipping, then it would slip when the AC is running and also when it's not.
 

·
Registered
Joined
·
6,471 Posts
When the A/C is on, there is a lot more stress placed on the belt drive and therefore a higher chance of slippage. The same goes for when you induce a high electrical load on the alternator, and when you turn the wheels all the way to the steering lock which places a high load on the P/S pump. Belt and belt tensioner condition would be key points to look at if there isn't a malfunctioning accessory (like a siezed compressor).
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
i think i'll replace the belt - prolly about time anyway and go from there.
i dont seem to have a belt routing diagram under the hood...anybody know where i might get one? or maybe i'm looking n the wrong place....
 
1 - 5 of 5 Posts
Top