Cadillac Owners Forum banner

1 - 1 of 1 Posts

·
Registered
2006 STS, 2007 STS-V
Joined
·
38 Posts
Discussion Starter #1
Has anyone had issues with the Body Control Module in their 05-06 STS? When I bought the car all previous settings were cleared and I went through the standard "welcome to your new cadillac" speach with the salesman setting up everything from scratch. Worked great. In no time I had my seat position saved for exit and driving, telescopic wheel position set for both, radio presets done, home address in the nav system etc.. All working great right?

A week or two later I started noticing some wierd stuff. Maybe I'd exit the car and get back in with the seat in a wierd position, maybe the telescoping wheel would not go up or down. Occasionally when I got in the seat even went all the way to the rear most position laying fully back. I could of course fight the controls and get everything back where it should be but was puzzled by this occurance. It stedily got worse, sometimes I ended up driving with the wheel in the full up position which is crazy. The car was purchased used with less than 40k on the clock. No bad history etc.. just out of the blue. I felt petty but finally caved and went in with 2 months worth of a log and talked to the dealership. They took 2 days and eventually came up with it being a problem with the Body Control Module. Much like a PCM apparently this is the piece that controls and retains control of the body programming and mechanisms. While they could not give me an exact explanation they did say that after several hours with cadillac techical support and their tech manager they decided to replace the full nave unit (I'm told the BCM is part of this unit).

Well, I got the car back and for the most part its been fine although on occasion when someone rides in the passenger seat it still tends to make my seat settings flake out. I had origionally assumed this may have been due to my wife's key settings but the last time it happened I specifically asked if she had her keys with her and she did not so that cancels out that possibility. I've also found that some functions dont seem to work while the car is in gear with your foot off the brake like the steering wheel telescoping in and out. The main thing is that its still occasionally happening. On top of this I seem to have lost some of the controls on my nave system. I used to be able to pause, ff and rew music as well as see a lot of the id3 taging on newer music cd's, dvd's and mp3 cd's. It appears this is no longer the case. Is it possible that the dealership replaced my nav unit with an older less equipped model? Maybe that or it has an older firmware revision so its missing these options? Trying to figure this all out. Again.. dont want to be petty and run back to the dealership with every little issue but its a bit concerning.

I'm also wondering if I should consider upgrading to the 08-09 Nav system with the built in hdd or even if I can do this. Anyhow.. any feedback would be appreciated. I'd like to get a lockpick kit but I'm waiting until I have this all bug free and cleared up so I dont hear complaints from the service guys when I have to take it in. Chances are they'd just blame the lockpick for the issues if it was on there. :confused:
 
1 - 1 of 1 Posts
Top