Cadillac Owners Forum banner

1 - 18 of 18 Posts

·
Registered
2007 EXT
Joined
·
270 Posts
Discussion Starter #1
Hey, 2007 Escalade ext with a isimple igsm651,

so for the past couple of days, i will come in my truck in the morning after driving it all day, and when i goto start the truck, nothing. The lights and everything turns on but nothing else, I have to jump it everyday, but in the day its fine ! but now it just dies over night. I have a radar connected so i think that might be the culprit but i also have isimple igsm651, but i always switch off my radio before i shut off the vehicle. and once when I was loading a tune, my truck battery died and the engine wouldnt start, so i needed a jump.

Is my battery messed? or something else?

if so, whats the best battery for our trucks. I dont want ac delco
 

·
Registered
1966 Mustang, 2007 Escalade EXT
Joined
·
93 Posts
I have an 07 EXT, I don't have these issues but then I don't any extra items connected. I found that the system with the key on draws a lot of power and left on long enough will drain a good battery, therefore I installed a second Battery. First, I would find what's drawing your battery down and take care of that, second I would add a second battery. Since I've added the second battery everything works great and there are no worries of a dead battery (I have Gel yellow Top Batteries)....Just My Opinion!
 

·
Registered
All Escalade Premiums, '16 ESV, '13 ESV, '10 EXT
Joined
·
617 Posts
This is a classic faulty battery, the amps required to start all of your electronics are not even close to the amount needed to start your car. Go get a free battery test at one of many shops (autozone, o'rielly, etc) and more than likely it will just need to be replaced. A second battery is not an adequate fix for a faulty primary, although the second battery is a good idea for other reasons but both must be in good health. dcarrer... really?... :helpless:
 

·
Registered
08 Escalade ESV awd, 05 Yukon Xl Denali awd, 06 SRX sold
Joined
·
1,852 Posts
I second the battery test, its the first step in diagnosing this type of complaint and in most cases its free
 

·
Registered
1966 Mustang, 2007 Escalade EXT
Joined
·
93 Posts
It's the alternator.
If the Alternator was faulty he would not be able to drive the vehicle....

----------

This is a classic faulty battery, the amps required to start all of your electronics are not even close to the amount needed to start your car. Go get a free battery test at one of many shops (autozone, o'rielly, etc) and more than likely it will just need to be replaced. A second battery is not an adequate fix for a faulty primary, although the second battery is a good idea for other reasons but both must be in good health. dcarrer... really?... :helpless:
Didn't say a second battery was the fix, clearly stated he should solve his problem first, then recommend adding a second battery...JMO!!!
 

·
Registered
All Escalade Premiums, '16 ESV, '13 ESV, '10 EXT
Joined
·
617 Posts
If the Alternator was faulty he would not be able to drive the vehicle....

----------



Didn't say a second battery was the fix, clearly stated he should solve his problem first, then recommend adding a second battery...JMO!!!
A valid opinion at that! That's why I said it was a good idea :) I have the dual battery setup and it's awesome, great for camping and tailgating!
 

·
Registered
2018 XT5 Platinum, 2014 S550
Joined
·
1,653 Posts
Simple Test on battery. Put meter on battery, should read anywhere from 11.5 up to 12.5 depending on how long the truck was sitting. Start the truck, if the alternator is working properly for the most part, you will be reading 13.5 to 15V. this is normal.
Depending on what year truck you have, you can display the voltage in the DIC, no meter needed.

AGM batteries are better than any WET Battery. If you want to keep stock looking and size battery, do a search on this forum and look for AGM type48 ACDelco. That is the exact side battery for the truck. Do a search on Amazon, you can get the battery delivered to your home for less than $160- ( Same Battery at Dealer over $300- plus installation )
:yup:
 

·
Registered
08 Escalade ESV awd, 05 Yukon Xl Denali awd, 06 SRX sold
Joined
·
1,852 Posts
Nice Ride said:
Simple Test on battery. Put meter on battery, should read anywhere from 11.5 up to 12.5 depending on how long the truck was sitting. Start the truck, if the alternator is working properly for the most part, you will be reading 13.5 to 15V. this is normal. Depending on what year truck you have, you can display the voltage in the DIC, no meter needed. AGM batteries are better than any WET Battery. If you want to keep stock looking and size battery, do a search on this forum and look for AGM type48 ACDelco. That is the exact side battery for the truck. Do a search on Amazon, you can get the battery delivered to your home for less than $160- ( Same Battery at Dealer over $300- plus installation ) :yup:
a battery with a bad cell in most cases will pass a test using a volt meter, it needs to be load tested
 

·
Registered
2018 XT5 Platinum, 2014 S550
Joined
·
1,653 Posts
I agree 100%, at least it will eliminate the Alternator as one source of the problem. I've had 4 OEM batteries replaced on my 09 by the dealer under warrantee. They only last about 2 years on average for me. I don't drive it much, so in the winter, if I have to jump it, I know its time to replace the battery. So far since I've switched to the AC Delco AGM48, no issues. Bothe the SRX and the Escalade take the same battery.
 

·
Registered
Joined
·
150 Posts
My 02 EXT has an issue with a dead battery too. Checked the alt and it's fine. Battery is a bit over a year old. This maybe a coincidence or not but the key fob broke and I replaced it with one from Amazon. Shortly after the battery started to drain. Any help.
 

·
Registered
2007 EXT
Joined
·
270 Posts
Discussion Starter #12
So I keep unplugging my radar and I think that's the culprit, my truck starts fine now if the radar isn't plugged in overnight, but the battery is probably bad
 

·
Registered
2018 XT5 Platinum, 2014 S550
Joined
·
1,653 Posts
I had AC Delco batteries go bad within 1 year, replaced by dealer under warrantee. I recommend you take a look at the AC Delco AGM Type48 Battery, its on Amazon at a great price. I replace my SRX 3 year old battery and did the Dual Battery Kit on the Escalade. All three batteries are the same. AC Delco Type48. Do some research on AGM instead of WET batteries.
 

·
Registered
2005 Cadillac Escalade
Joined
·
1,177 Posts
Nice Ride said:
I had AC Delco batteries go bad within 1 year, replaced by dealer under warrantee. I recommend you take a look at the AC Delco AGM Type48 Battery, its on Amazon at a great price. I replace my SRX 3 year old battery and did the Dual Battery Kit on the Escalade. All three batteries are the same. AC Delco Type48. Do some research on AGM instead of WET batteries.
There's only 4 or so battery companies out there. It's all the same stuff different labels. Most come with a warranty and should swap them out free of charge. Delco most likely doesn't make the batteries in house ----------
hnijhar said:
So I keep unplugging my radar and I think that's the culprit, my truck starts fine now if the radar isn't plugged in overnight, but the battery is probably bad
Does the fuse go off after 15 min? Or when u turn key off
 

·
Registered
2007 ESCALADE ESV
Joined
·
45 Posts
Did you figure out what it was, this tends to happen intermittently when it rains or gets a bit chilly on my 07 esc as well, & i have the isimple connected as well. I always hear sounds after i turn the car off, & the days it dies, while I'm boosting it, it starts making noise with the car off. I'm at a lost. I had the 1 battery solution on my 07 suburban, but I'm sure this would happen again even with 2 batteries, I have a platinum die hard, the best one they had.

Did you find a solution? thanks!
 

·
Registered
2013 Platinum ESV 2015 MB GL550 2008 Hummer H2
Joined
·
1,071 Posts
Yeah its common on all 2007-2014 models. Even my 2008 Hummer H2 has the same battery issue.
 

·
Registered
2007 EXT
Joined
·
270 Posts
Discussion Starter #17
it was the alternator. replaced alternator and kept the same battery and it's good. never dies. I simple and the Radar were not the culprit. but if you have I simple I would recommend that you switch to fm or am before you shut the vehicle off and then push the nav button in to switch the nav screen off and then shut off vehicle. I've been doing this for almost a year with the I simple and I have had 0 problems :))
 

·
Registered
2007 ESCALADE ESV
Joined
·
45 Posts
Its crazy, I seldom shut the music & nav off, but I've been doing it, & no problems, I wishhhhhh, I knew this years earlier, recall being out on dates during winter & it just dying. So far so good, thanks a lot for the advice!
 
1 - 18 of 18 Posts
Top