Cadillac Owners Forum banner

21 - 40 of 43 Posts

·
Registered
Joined
·
4,193 Posts
I see it sold. Good choice. $290, I was afraid of that, that's three $95 diagnostic fees. I'd ask them what took them so long and why didn't they get it right the first time ??? There's a Customer Service thread here you can complain to that you can use for leverage to get the dagnostic fee reduced.
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #22
Well put the other AMP on Monday today car won't start again. Started pulling fuses found the trunk latch is draining keeps waking up other modules, now remote is not working with fuse out,on the fuse it says( trunk lock latch) put fuse back in it works.I'll just leave fuse out for now.With fuse in unpluged from latch it still drains, relay out same. It only stops fuse out.
Any Ideas whats going on?

Thanks
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #23
Same fuse powers the radio antenna module so its most likely the radio antenna module that keeps waking up other modules draining the battery. Shame on the dealer for telling me its the amp and kept the car for 9 days they will get a phone call tommorow. What do you guys think? The guys at work keep joking about the car light it up,dump it. Im not giving up. Thanks
 

·
Registered
Joined
·
4,193 Posts
Did you check the trunk release button on the driver's door ? Maybe its stuck on. Try pushing it a few times to see. If it operates cleanly, that button may be shorted. Remember that circuit is always available because you can operate the trunk without the key in the ignition. There is a module underneath the headlining at the rear windshield that recieves the remote transmitter signals. It controls the trunk release and the door locks at the least. That module might have a problem, but the dealer had plenty of time to identify the problem so its up in the air. Did you understand everything the dealer told you ? It may be that module not the amp, or at that price it might be both. Good luck.
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #25
The car has been starting so far in the morning the DIC its reading 12.5V before cranking. So its that circuit. The dealer told me radio amp left side in trunk as soon as I pluged the other amp 2 days later battery was dead,called them the other day told them its radio ant. module. He said they will program the remotes for free if I install it he did not say anything about refund the tech.was for sure its the amp and chaseing circuits is time consuming,the new part is $100 on amazon. I unpluged the trunk latch and button on door it was draining. Over the weekend ill unplug the ant. And put the fuse back and test it. Thanks X Rolls for your help.
 

·
Registered
Joined
·
4,193 Posts
Well, I'm limited as to what I can do from this distance, but the dealer had it for three days and their failure is inexcusable.

His offer to reprogram the fobs has value but its still pretty lame.

Let's get the car fixed and then we can go to work on the dealer. The Cadillac Customer Service representative attached to this Forum has been very helpful in the past.
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #27
I took out the Radio Ant. Module, fuse in place and the DMM is steady at 9 millivolts. New part is on it's way. Watched some videos on you tube,guy says on late models its normal up to 30 millivolts.
This where I'm getting the 9 MV.
1. ECM/TCM---------2MV
2. PSGR DR MOD----1MV
3. DIM/ALDL---------1MV
4. REAR DR MOD----2MV
5.DRIVER DR MOD--2MV
6.AUDIO-------------1MV
Are these readings normal?
Do I need to get it lower? The battery is holding 12.5 V every morning for the past 10 days with the fuse out.
Thanks for all the input
 

·
Registered
'09 Chrysler 300C, *''03 CTS is gone"
Joined
·
235 Posts
I have the same problem as you with my 03 CTS. Every night my car is plugged to the battery charger otherwise the battery would be empty.
I have the Bose system in my car. I also changed the amp. I noticed at the time my amp were unplugged the battery remained about 3 days without charging, now I have my amp plugged back in the car and the battery will be dead within one night.

As I understand it you have solved your problem by pulling out the “Radio Ant. Module” fuse. Where is this fuse located, I want to try it too.
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #35 (Edited)
The fuse is under rear seat driver side look at owners manual. It's marked (trunk dr release). I have the base model it only powers Radio ant. module and trunk latch. I see you have the luxury model on the wiring diagram it showed trunk, radio ant. garage door opener and intrusion sensor. You will loose any options of these you have plus key fob won't work.
Good luck
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #36
Just wanted to finish this threat the car is fixed no more draining the battery, put the new Radio ant. module, key fobs reprogramed DMM is reading 0.011 amps, 0.010 volts.
Thanks to ereryone for the help.:):eek:
 

·
Registered
Joined
·
4,193 Posts
Just wanted to finish this threat the car is fixed no more draining the battery, put the new Radio ant. module, key fobs reprogramed DMM is reading 0.011 amps, 0.010 volts.
Thanks to ereryone for the help.:):eek:
Was it the antenna module that was draining the battery ?

----------

Dealer called today, they say the AMP is draining the battery. $800 +tax for new AMP is this what they go for.
If it was the antenna module, what does the dealer have to say about his misdiagnosis ?
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #38
Yes it was the ant. module, I had my cousin reprogram the key fobs with Tech 2. I'm not even going to bother with the dealer I'm just happy the car is fixed. Total cost for the fix $492 it could of just been $102 for the ant module. I now have spare Amp $100, dealer $290 for doing nothing.
thanks
 

·
Registered
Joined
·
4,193 Posts
Yes it was the ant. module, I had my cousin reprogram the key fobs with Tech 2. I'm not even going to bother with the dealer I'm just happy the car is fixed. Total cost for the fix $492 it could of just been $102 for the ant module. I now have spare Amp $100, dealer $290 for doing nothing.
thanks
I would demand a refund. I'm glad the car is good again.
 

·
Registered
2006 cts 3.6L Stealth Grey / Luxury
Joined
·
232 Posts
I now have spare Amp $100, dealer $290 for doing nothing.
Don't feel bad. I just paid a guy $209.00 today to tell me that the heat exchanger in my furnace at home is shot and that it will cost somewhere around 4k to replace the furnace with a new one. Not too happy at the moment.
 
21 - 40 of 43 Posts
Top