Cadillac Owners Forum banner

1 - 20 of 43 Posts

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #1
Hello
The battery is dead overnight and it's 2 weeks old. I did test with DMM on the negative cable and got 1.97A.
Started pulling fuses, the 2 that drained the most are Audio(radio, onstar module) and Amp(audio amplifier) with these two out I get 0.49A. The onstar was updated to digital 4yrs. ago what is normal current draw for this car.Everything was off doors closed.
The car has 65k mi.
Thanks any suggestions is appreciated.
 

·
Registered
2003 CTS 1SC Luxury Sport
Joined
·
1,017 Posts
Normal drain on any car should be 0.2 amps or less. I saw a few TSB's about this a couple of days ago when I was bored at work. So you found your main draw but you still have a draw somewhere.
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,767 Posts
When you tested the wires, I see you had the doors closed. Which is good, however how long were they shut? Because when I tested mine, years ago, it was hight as well. But then after 1 to 2 minutes the amperage dropped. Came back up as soon as I opened a door, then it took a couple minutes after closing the door.

KOT
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #4
I waited 15 min same reading disconected the amplifier onstar module got 0.95A I'm looking at wiring diagrams from alldata I hope I can figure out whats going on otherwise trip to dealer. I thing the radio is the problem plus it's cold outside can't work to long.

Thanks for the replys
 

·
Registered
CTS 03
Joined
·
1,765 Posts
Some of the early 03s had a problem with the Dome light switch, if you leave it too far forward, it would drain the battery. There was a recall for that years ago. You may want to keep your meter on and pull the fuses one at a time to see if it drops. If it drops after you pull a fuse, go after that circuit. When I tested mine, it was .13amp if I pull the R Rear fuse it dropped to .05a. Some folks get water in the trunk on the drivers side and the amp gets wet and causes problems.
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #6
After looking at the wiring diagrams I noticed that radio, amp are connected to the DLC. My cousin has scanner for GM. There were a few DTC in circuits, erased all of them. Maybe a module wasn't going to sleep there were to many DTC in circuits to write down. Hooked up the DMM and it read 0.07A. I hope it stays that way I'll do another test in a few days see what happens.

Thanks
 

·
Registered
2003 CTS 1SC Luxury Sport
Joined
·
1,017 Posts
Sorry I wanted to correct myself on my earlier post. The acceptable draw is 5 milli amps. There are a TON confirmed fixes on identifix for bad BCM's causing battery drain. All were related to OnStar and the radio
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #8
This is getting weird!!
One day DMM shows normal 3mv the next day it shows 2.1v. I gave up, took the car to dealer, Tuesday, they called back everything is normal 2.7mv,want to keep the car overnight see if it will start in morning. Wed. they call say to come and pick up the car everything is ok. I told them I'll come Friday I knew the problem wasn't solved. Today battery dead nothing. Now they want to keep it over the weekend and look at it on Monday.

Any ideas on whats going on?

Thanks
 

·
Registered
Joined
·
4,193 Posts
Was the car working right before you changed the battery ? If so, you may have gotten a bad battery. The energy management system should have cut off anything drawing on the battery. As it is, you are building a huge bill at the dealer unless he has exceptional integrity.
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #10
Dealer called today, they say the AMP is draining the battery. $800 +tax for new AMP is this what they go for.
Can I install aftermarket Amp?

Thanks
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,767 Posts
There are several on eBay for less than $100 right now.

Just make sure which one you need. Bose or non Bose. Either way, it's a plug and play. No need to reprogram or anything.

Just say "thanks but no thanks mr stealership."

KOT
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #12
Thanks for the reply KOT.
I was just looking on ebay, I have the Delphi Amp. What I don't understand is Code Uxx. Where do I look this up?

Thanks
 

·
Registered
Joined
·
4,193 Posts
The "U" codes are option codes for the different audio systems.

U2K is XM satellite radio, U2S is the Bose 6 disc system, U57 is the 8 speaker package. Your codes are on a sticker on the underside of the spare tire cover in the trunk. U30 is the instrument cluster, UA6 is the alarm system, UE1 is the OnStar, and UG1 is the garage door opener.

The amp always draws power because it powers the door chimes and is ready for instant response. The early models had a problem but the recall should have fixed it.
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,767 Posts
Actually X-Rolls, there's a relay in the amp turns on just for the "hey dumbass" bong. So the amp is only on when a door is opened, either from inside or outside. Or when the remote is used for whatever reason. And if you sit in the car and wait until everything is off. Then turn on the interior lights, and the amp turns on.

KOT
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,767 Posts
X Rolls-Royce said:
Okay, so the recall for the early models addressed the amp staying on when it was supposed to be off ?
Are you thinking of the malfunction radio? It was more of an inconvinious. It was just displaying funny symbols nothing more.

KOT
 

·
Registered
Joined
·
4,193 Posts
I remember rightly or wrongly something related to the amp. There was also a problem with the dimmer switch in the full on position draining the battery on the 2003.
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #18

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,767 Posts
So get it and save $700. It's easy to installed too. 4 nuts, 5 or 6 plugs and your done. Each plug is different, so you can't goof up.

KOT
 

·
Registered
2003 CTS
Joined
·
30 Posts
Discussion Starter #20
More like $960 including labor replacing the amp, they billed me $290 for finding the problem, the car sat there for 9days. OK I'm buying it.

Thanks again
 
1 - 20 of 43 Posts
Top