Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
2002 Escalade, 1996 Fleetwood Brougham
Joined
·
32 Posts
Discussion Starter #1
Qucik short story of my promblem.....My automatic locks stopped working in my 96 FWB, no power to the locks from inside, factory alarm (checked batt.= good still) power locks no longer work, shifting into gear does locks the doors or unlock the door when shifting in to park. Glove box trunk release no longer works (have to use the key). Did I some how disable this with the alarm? The keys were in my pocket (leaning against some coins I guess) as I was walking to the car my trunk popped open - then the all the problems above happend from there on end. I checked all the fuses there all good - no burn outs from what I can see - Any Ideas on what happend? Here is a picture of the key alarm I have.
 

Attachments

·
Registered
1985 Cadillac Fleetwood Brougham d'elegance - 1969 Coupe DV (R.I.P.)
Joined
·
655 Posts
hmmm i honestly dont know. i had a friend with this problem and ill ask him and see what i can dig up. his was a ford so i dont know if itll be the same thing but its worth a try
 

·
Registered
1985 Fleetwood Brougham 1996 Cadillac Fleetwood Brougham
Joined
·
120 Posts
That looks like an aftermarket keyfob.

Anyways, I am assuming that everything was working before.
It could be one of the many relays tied in with the power locks.

A couple of questions:
Are your courtesy lights on when you are driving? Does your pull down motor pull the trunk down? Does your radio stay on for 10 minutes after shutting the car off (it is supposed to do this, BTW).


I had some electrical issues that popped up a few months ago. Alarm going off in the middle of the night, then no security light arming the car. Trunk issues( not opening, nor closing, locks not locking when in drive, but the courtesy lights stayed on.


I had first Checked the ground 400 located at the driver's side trunk hinge for damage. This is a known issue for this car.

Then I tested the trunk release solenoid/actuator and pull down motor, actuator failed and I had a bad switch on the motor.

The courtesy lights stayed on while in drive and the auto locks did not lock.

Spray the latches in the doors with WD40 and see if that might get things moving. The latches are an electromechanical devise with levers and arms and mechanical parts that tie into the security and convenience features.

This is just a start. Then if you don't have one get a FSM. (the spraying of the latches is not really listed in the diagnosis of the problems I had, I got that advice from here on the forum.)

Hope this helps
 

·
Registered
2002 Escalade, 1996 Fleetwood Brougham
Joined
·
32 Posts
Discussion Starter #4
That looks like an aftermarket keyfob.

Anyways, I am assuming that everything was working before.
It could be one of the many relays tied in with the power locks.

A couple of questions:
Are your courtesy lights on when you are driving? Does your pull down motor pull the trunk down? Does your radio stay on for 10 minutes after shutting the car off (it is supposed to do this, BTW).


I had some electrical issues that popped up a few months ago. Alarm going off in the middle of the night, then no security light arming the car. Trunk issues( not opening, nor closing, locks not locking when in drive, but the courtesy lights stayed on.


I had first Checked the ground 400 located at the driver's side trunk hinge for damage. This is a known issue for this car.

Then I tested the trunk release solenoid/actuator and pull down motor, actuator failed and I had a bad switch on the motor.

The courtesy lights stayed on while in drive and the auto locks did not lock.

Spray the latches in the doors with WD40 and see if that might get things moving. The latches are an electromechanical devise with levers and arms and mechanical parts that tie into the security and convenience features.

This is just a start. Then if you don't have one get a FSM. (the spraying of the latches is not really listed in the diagnosis of the problems I had, I got that advice from here on the forum.)

Hope this helps
No courtesy lights on when I'm driving. Trunk works fine only with key tho. the motor does pull the trunk down, but does not work from the glove box. Yes the radio stays on until the door is open or 10 min has passed. It seems as if I disabled something- it just wierd.

Here is something interesting when all the door are unlocked, when pressing the alarm to unlock the doors - every door except the drivers door locks - this is the only time when the door locks work - the electric way. Would getting a whole new alarm system fix this problem?
 

·
Registered
1985 Fleetwood Brougham 1996 Cadillac Fleetwood Brougham
Joined
·
120 Posts
IIRC during my electrical issues, disconnecting the Theft deterrant module caused the problems you describe. If your ground is broken then the theft module will not work. This module uses the ground that I had mentioned in my previous post. What happens is that the wire is too short and probably should have been routed differently at the left trunk hinge when thy designed the car. Check this first, many of the different components in rear of the car use this as a common ground. You can't miss it once you open the trunk and look under the speaker shelf.
 

·
Registered
2002 Escalade, 1996 Fleetwood Brougham
Joined
·
32 Posts
Discussion Starter #6
IIRC during my electrical issues, disconnecting the Theft deterrant module caused the problems you describe. If your ground is broken then the theft module will not work. This module uses the ground that I had mentioned in my previous post. What happens is that the wire is too short and probably should have been routed differently at the left trunk hinge when thy designed the car. Check this first, many of the different components in rear of the car use this as a common ground. You can't miss it once you open the trunk and look under the speaker shelf.
elk9300, thanks for your help, I checked the ground on the trunk hinge it was all good, no damage or anything funky. Once again went and looked at all the fuses, all good as well. Here is the kicker - I went and bought a brand new car battery (did not know the age of the current batt.) change it to the new batt. and everything is now working correctly. VERY strange how the cars system would eliminate some power sources of the car. Thanks again for your tips.
 
1 - 6 of 6 Posts
Top