Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
STS
Joined
·
33 Posts
Discussion Starter #1
This just started happening recently. What normally happens is the lights are set to auto on, and upon leaving the garage during the day, they will shut off within a minute of leaving the garage. Not sure what has happened but as of last week, they never shut off while the car is running unless I manually move the switch to auto lights off. I tried wiping the sensor in the middle of the dash clean from dust/debris with no impact. Is there another sensor somewhere I'm missing that could be causing this? The only way to turn off the lights is to set the switch.

Car is a 2007 STS V6 w/projectors (non-HID).
 

·
Registered
2006 STS4 V8 1SG & 2007 STS V8 1SE
Joined
·
8,178 Posts
The day I picked up my car, another STS owner asked me how to get the running lights to come on. At the time I didn't understand. It's all about the Rainsense wipers!
 

·
Registered
2006 STS V8 1SF RWD
Joined
·
6,479 Posts
I learned this in my 01 Seville...This is because many states, like MN, mandate by law that headlights are on during any precipitation...

Valet lock got me with the gas cap in that car too...Opened the gas flap with a credit card for a week before I realized it :)
 

·
Registered
STS
Joined
·
33 Posts
Discussion Starter #7
That was a new one, thanks for the quick fix! Apparently I'm still learning things about this car.
 
Joined
·
12,778 Posts
PzNuts, I'm happy to see the community step in to help! If you have any additional questions, I hope you'll keep us in the loop. Please email me anytime at [email protected] if you would ever like me to research questions further for you in the future.

Best,

Katie
Cadillac Customer Service
 
1 - 8 of 8 Posts
Top